[Flame] Face detection does not work in video mode

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: njpark, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Reporter)

Description

4 years ago
STR:
Open camera, set to photo mode, and point to a face.  check face circle appears.
Change to the video mode, and point to the same face.

Expected:
Face detection circle appear
Actual:
Face detection circle does not appear

Picture mode :    http://goo.gl/5Jg7mm
Video mode: http://goo.gl/MNPFDQ

Version Info:
Gaia-Rev        3e585d8be5e2dffc376f83313299c9b6d53c3db4
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/b643d78a23c6
Build-ID        20141030001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141030.035245
FW-Date         Thu Oct 30 03:52:56 EDT 2014
Bootloader      L1TC00011880
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:
Key feature is broken, and it's a regression
blocking-b2g: --- → 2.1?
Keywords: regression
(Reporter)

Comment 2

4 years ago
This also reproduces in 2.2 as well
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
When recording a video, the driver doesn't support face detection. It would only work in the preview in the past. Due to some other issues, we disabled that in bug 1081270.
Depends on: 1081270
Clearing the nomination here per comment #3.
Status: NEW → RESOLVED
blocking-b2g: 2.1? → ---
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

4 years ago
  ni?ing hema to double check that we're okay with disabling face detection on camcorder side, in terms of feature requirements.
Flags: needinfo?(hkoka)

Comment 6

4 years ago
Face Detection is not supported for video recording mode only.

Updated

4 years ago
Flags: needinfo?(hkoka)

Updated

4 years ago
Keywords: regression
You need to log in before you can comment on or make changes to this bug.