Closed Bug 1091635 Opened 7 years ago Closed 7 years ago

e10s - Web Content process pins the CPU after killing the UI

Categories

(Firefox :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1059775
Tracking Status
e10s ? ---

People

(Reporter: lth, Unassigned)

Details

When the UI process hangs, and is killed from eg the System Monitor (Ubuntu), the Web Content process tends to go into an infinite loop that takes 100% of one core.  The Web Content process needs to be killed separately.

Better would be if the Web Content process could discover that its UI process has gone away.

I assume this is e10s related.

(Ubuntu 14.10.)
tracking-e10s: --- → ?
Summary: Web Content process pins the CPU after killing the UI → e10s - Web Content process pins the CPU after killing the UI
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1059775
You need to log in before you can comment on or make changes to this bug.