Reply fails if IMAP folder name has comma in it

VERIFIED DUPLICATE of bug 133861

Status

MailNews Core
Composition
VERIFIED DUPLICATE of bug 133861
17 years ago
10 years ago

People

(Reporter: Henry Throop, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I have a folder named 'JPL, telecons' stored on an IMAP server.  If I select one
of the messages in this folder and hit either 'Reply' or 'Reply All', a blank
composer window comes up -- no message:, no subject:, no to:.

If I rename the IMAP folder to remove the comma ('JPL telecons') then 'Reply'
works again.  The folder was originally created with Mozilla, and is stored on
the server with the proper filename (no escape characters, etc.)

Also, if I copy the message to another folder, open it, and hit 'Reply', it
works like it's supposed to, with the proper fields filled in. 

Bugs 23789 and 29926 look similar to this one, as they deal with forbidden
characters in folder names.  This bugs looks different than those, because it
affects only 'Reply'.  Unlike those bugs, I can read, copy, move, etc. the
message with no errors.

Server is IMAP4rev7 (redhat 7.1).  Mozilla is 2001101202.

Comment 1

16 years ago
karen,
This is most likely a dup bug. I will mark it when I find it 
QA Contact: sheelar → huang

Comment 2

16 years ago
reporter, is this still a problem in the recent builds or 0.9.9?
(Reporter)

Comment 3

16 years ago
Yes, bug is still there (as of 2002031808), in that having the comma in the IMAP
folder name causes the reply to fail.  However, the behavior is different.  When
originally reported, the mail compose window came up, just blank.  Now, I get
the error message:

  'An error occured while creating a message compose window.  Please try again.
   
   [ '

(The stray '[' is part of the messge.)

So, Mail appears to see that something is wrong, which it didn't do originally.
 Nevertheless, the comma is still causing the problem.

I don't know if it's related, but intermittently, instead of getting the error
window, Mozilla crashed.  TB ID TB4903860X.

Comment 4

16 years ago
found it. the bug number for this is bug 133861.
i also modified the summary there to make it easier to find.

I will also post your talback id there.

*** This bug has been marked as a duplicate of 133861 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.