Follow-up Bug 1081143 Message handler is not invoked when a datastore change message

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: jmcf, Assigned: ferjm)

Tracking

Trunk
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Take Francisco's example app found in Bug 1081143 and it can be tested that the messageHandler is not invoked. 

Furthermore, the app needs a new permission to work. We need to revise the datastore sys msgs implementation as it seems to be incorrect.
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 2.2?
Hi baku, I can confirm that I dont get the system message, should we repone bug 1081143? So far is the same issue, the app is being opened by the system message, but the system message itself is not being caught.

Or, perhaps the code we are using for catching the system message is wrong :)

Thanks!
Flags: needinfo?(amarchesini)
(Assignee)

Updated

4 years ago
Assignee: nobody → ferjmoreno
(Assignee)

Comment 2

4 years ago
The problem is on the contactslistener.zip test app attached to bug 1081143. The app is listening for "datastore-updated-contacts" (note the final 'd' in '-updated-') while it should be listening for "datastore-update-contacts". I'll update the test app on that bug just in case someone wants to use it for testing this feature again. Sorry for the noise about this Andrea.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(amarchesini)
Resolution: --- → INVALID
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.