If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Scrolling down fails in Etherpad

RESOLVED WORKSFORME

Status

()

Firefox
Keyboard Navigation
RESOLVED WORKSFORME
3 years ago
27 days ago

People

(Reporter: alex_mayorga, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox35 ?, firefox36 affected, firefox39 affected, firefox40 affected, firefox41 affected, firefox42 affected, firefox-esr31 affected, firefox-esr38 affected, firefox57 fixed)

Details

(Reporter)

Description

3 years ago
Steps:
- Load https://remo.etherpad.mozilla.org/call-30-10-14
- Press <Page Down> key repeatedly

Result:
Page scrolls back to top on second key press.

Expected result:
Page continues to scroll down.

Comment 1

3 years ago
Also seen on Linux.

Also: Scroll to the bottom of the page and press page up. The first few work, then looping starts. The behavior changed with changes in the window size.
OS: Windows 7 → All
status-firefox35: --- → ?
status-firefox36: --- → affected
Keywords: regression, regressionwindow-wanted
Version: Trunk → 36 Branch

Comment 2

3 years ago
Hi Alex,

We have a handy tool that can help you with this: https://github.com/mozilla/mozregression. It is an interactive tool that will automate the downloading and deploying of temporary firefoxes so that you can then verify that the issues has reproduced or not in each build, and it will help you narrow down the regression range.

We also need you to specify what build you're actually running so we know where to start with the regression hunting browse to about:buildconfig, and that will tell us.

If you need qa help for this, please add the qawanted keyword as well and it will get into our backlog of requests. Thanks for trying it yourself though if you can!

Comment 3

3 years ago
This does not appear to be a regression in that it appears it never worked properly before.

Jan 2011 and 2012 builds:
Page down does not work at all

Jan 2013 build:
Page down scrolls a bit once.  You then have to click to refocus the textarea to be able to page down a bit again.  And repeat...

2014 builds:
Behavior as described in comment 0

Comment 4

3 years ago
And Chrome and IE PgDown scrolls all the way to the end instead of only scrolling down one "page".
I'd say it's the site's script that's wonky.

Comment 5

3 years ago
tried to test this bug with following and reproduced this bug.

Windows 7 ultimate
Name: Firefox nightly
Version: 39.0a1
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
build id: 20150320030211

Name: Firefox developer edition
Version: 38.0a2
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
build id: 20150320004008

Bug found on above those browsers.


Also tried with other browser like
google chrome Version 41.0.2272.89 m and internet explorer v11.0.9600.17691

but no issue found on above those browsers. Page perfectly continues to scroll down.

Comment 6

2 years ago
I tried on chrome41 and IE11 on windows7.
PageDown makes scroll to the bottom. And PageUp makes scroll to the top.

Chrome44dev, triple keypress needed.

So, anyway the site is something buggy.
(Reporter)

Comment 7

2 years ago
This is still a problem on Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0 ID:20150722030205 CSet: 8e5c888d0d89
status-firefox39: --- → affected
status-firefox40: --- → affected
status-firefox41: --- → affected
status-firefox42: --- → affected
status-firefox-esr31: --- → affected
status-firefox-esr38: --- → affected
See Also: → bug 871553
Version: 36 Branch → Trunk
Comment 3 indicates that this isn't a regression (never worked in the first place), so removing the keywords corresponding to that.
Keywords: regression, regressionwindow-wanted
(In reply to alex_mayorga from comment #0)
> Steps:
> - Load https://remo.etherpad.mozilla.org/call-30-10-14
> - Press <Page Down> key repeatedly

Do you have an alternate testcase?
Flags: needinfo?(bj)
Flags: needinfo?(alex_mayorga)
Summary: Scrolling loop on Etherpad → Scrolling down fails in Etherpad

Comment 10

a month ago
Sorry, no other test case. I only use Etherpad when pointed to it by some Mozilla event and the Etherpad references saved in my browser history don't seem to have a scrolling problem.
Flags: needinfo?(bj)
(Reporter)

Comment 11

27 days ago
¡Hola Wayne!

Tried to reproduce the bug on https://public.etherpad-mozilla.org/p/remo-call-10-08-2017 and failed.

¡Gracias!
Alex
Status: NEW → RESOLVED
Last Resolved: 27 days ago
Flags: needinfo?(alex_mayorga)
Resolution: --- → WORKSFORME
(Reporter)

Updated

27 days ago
status-firefox57: --- → fixed
You need to log in before you can comment on or make changes to this bug.