[Usage] When setting 'Data usage limit' certain numbers are not accepted

RESOLVED DUPLICATE of bug 1073340

Status

RESOLVED DUPLICATE of bug 1073340
4 years ago
4 years ago

People

(Reporter: rmead, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-exploratory-3])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8514644 [details]
2014-10-30-15-46-51.png

Description:
When setting 'Data usage limit', certain decimal numbers are not accepted. (ex: 2.05, 8.05, 9.05, 10.05)
  
Prereq:
Have a device with an active SIM card in it.
 
Repro Steps:
1) Update a Flame device to BuildID: 20141029001202
2) Tap 'Usage' app and go through set up process
3) On the main page, tap the settings icon in the upper right corner
4) Enable the toggle switch "Data use alert"
5) Tap the text box below it with the header "When use is above"
6) Set the limit to any of the following: 2.05, 2.18, 8.05, 9.05, 10.05 and observe
  
Actual:
The text box turns red and you cannot select the 'done' button
  
Expected: 
You should be able to enter any number without the text box turning red


Flame 2.1(319mb)(KitKat)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141029001202
Gaia: eb0aab0f13c78c7ac378ad860e865c4b6eaf669f
Gecko: 318019f80a8e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 100%
See attached: logcat, screenshot
(Reporter)

Comment 1

4 years ago
Created attachment 8514645 [details]
Flame2.1logcat.txt
(Reporter)

Comment 2

4 years ago
This issue DOES occur on Flame 2.0(319mb)

When setting 'Data usage limit', some decimal numbers are not accepted.

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141029000205
Gaia: 9f5b6f025e528fabfcc068782cb9b492cb51a7f9
Gecko: de8cfd54bf93
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


This issue does NOT occur on Flame 2.2(319mb)

When setting 'Data usage limit', all numbers are accepted

Flame 2.2

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141029040208
Gaia: 35e87ac4324f0f3abd93dcc70d61c9f37256a0f5
Gecko: 7e3c85754d32
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Hi Robert, 
I thought that the patch for the "Bug 1089829 - [Usage] Incorrect characters display when setting a data limit that exceeds 17 characters" fix this issue, I've already asked for approval to 2.1.

Regards
Depends on: 1089829
Not going to nominate to block on this since this is on 2.0 as well and this issue has already been resolved on master.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?
Resolution: --- → DUPLICATE
Duplicate of bug: 1073340
You need to log in before you can comment on or make changes to this bug.