Closed Bug 1091928 Opened 5 years ago Closed 4 years ago

[Flame] [Intermittent]User cannot add smart collections to homescreen

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: pensacola_m2000, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Gaia   0dfc1996eb583c8b507a82bf6b8319624bba23ea
SourceStamp 80e18ff7c7b2
BuildID 20141030040201
Version 36.0a1
v188 base image
2.2.0 nightly build

Steps to reproduce:
1. Long press on the Homescreen
2. Select 'Add Smart Collections'

Expected results:
User should be able to add smart collections to homescreen

Actual results:
User cannot add smart collections to homescreen. After selecting 'Add Smart Collections' option a Loading spinner is displayed, but nothing happens. Also please note that pressing the Cancel button does not have any effect.
Keywords: regression
Note:
Reproduction Frequency: 1 out of 5
Marcela: I haven't been able to repro on Flame using:

Gaia   8ae6598f3ab7b0c34ac42a73083ddb74266affba
SourceStamp e0b505a37b1c
BuildID 20141030160200
Version 36.0a1
v 188

I got the spinner as well, but after a second or so the collections were added.
(In reply to Marcia Knous [:marcia - use needinfo] from comment #2)
> Marcela: I haven't been able to repro on Flame using:
> 
> Gaia   8ae6598f3ab7b0c34ac42a73083ddb74266affba
> SourceStamp e0b505a37b1c
> BuildID 20141030160200
> Version 36.0a1
> v 188
> 
> I got the spinner as well, but after a second or so the collections were
> added.

It might be same cause as https://bugzilla.mozilla.org/show_bug.cgi?id=1091925. I will try to reproduce it again and attach some logs, because the bug is definitely intermittent.
(In reply to Marcela Oniga from comment #3)
> (In reply to Marcia Knous [:marcia - use needinfo] from comment #2)
> > Marcela: I haven't been able to repro on Flame using:
> > 
> > Gaia   8ae6598f3ab7b0c34ac42a73083ddb74266affba
> > SourceStamp e0b505a37b1c
> > BuildID 20141030160200
> > Version 36.0a1
> > v 188
> > 
> > I got the spinner as well, but after a second or so the collections were
> > added.
> 
> It might be same cause as
> https://bugzilla.mozilla.org/show_bug.cgi?id=1091925. I will try to
> reproduce it again and attach some logs, because the bug is definitely
> intermittent.

I was able to reproduce the issue, but unfortunately i don't have logs, because I cannot connect my device to adb. Basically developer mode is being disabled and cannot be enabled anymore only after rebooting phone (ehnr this bug appears). Also, after this bug occurs I'm unable to make any call, pressing on Call button does not have any effect.
Steps to reproduce:
Make some calls, open camera (basically use the phone as your primary device), and after a while try to do the steps mentioned in bug description.

I know that the steps are not clear but the bug is intermittent, so I did not find the exact scenario.
Summary: [Flame] User cannot add smart collections to homescreen → [Flame] [Intermittent]User cannot add smart collections to homescreen
The issue is reproducing using:

Build number:39
OS version: 2.2.0.0 prerelease
platform version: 36.0a1
Build identifier: 20141110040206
Nightly build
e
When trying to add smart collection I got the loading spinner and then a black screen. So I'm unable to select and/or add them to screen.
Marcela: Are you ever seeing the Geolocation prompt prior to this happening? And if so do you share your location?
Flags: needinfo?(pensacola_m2000)
(In reply to Marcia Knous [:marcia - use needinfo] from comment #6)
> Marcela: Are you ever seeing the Geolocation prompt prior to this happening?
> And if so do you share your location?

Geolocation is ON. I uploaded a small video to dropbox https://www.dropbox.com/s/b3j9mmff8n8gidc/VID_20141111_205932.mp4?dl=0.
I'm attaching some logs.
Attached file logSmart.txt
Flags: needinfo?(pensacola_m2000)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.