[Window Management]Multiple applications will flicker black or white when going into card view

REOPENED
Unassigned

Status

Firefox OS
Gaia::System::Window Mgmt
REOPENED
3 years ago
3 years ago

People

(Reporter: cnelson, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-Exploratory-3], URL)

Attachments

(1 attachment)

4.69 KB, text/plain
Details
(Reporter)

Description

3 years ago
Created attachment 8514687 [details]
logcat.txt

When going into card view with the Gallery, Video, Camera, Music, and Usage applications the user will notice that the app will flicker black or white.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141029001202
2) Open the Video, Gallery, Music, Camera, or Usage app.
3) Then hold the home button to put the app into card view.
4) Notice the app will flicker black or white for a moment.
  
Actual:
Multiple applications will flicker when putting them into card view.
  
Expected: 
No applications will flicker when putting them into card view.
  
Environmental Variables:
Device: Flame 2.1
BuildID: 20141029001202
Gaia: eb0aab0f13c78c7ac378ad860e865c4b6eaf669f
Gecko: 318019f80a8e
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Notes: The Usage application is the most severe out of all the apps.
  
Repro frequency: 100%
See attached: logcat, video clip https://www.youtube.com/watch?v=OizYZcprXjM
Flags: needinfo?(dharris)
(Reporter)

Comment 1

3 years ago
This issue doesn't occur on Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash), and Flame 2.0 (319mb)(Kitkat Base)(Full Flash).

No applications will flicker when putting them into card view.

Flame 2.2

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141029040208
Gaia: 35e87ac4324f0f3abd93dcc70d61c9f37256a0f5
Gecko: 7e3c85754d32
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141029000205
Gaia: 9f5b6f025e528fabfcc068782cb9b492cb51a7f9
Gecko: de8cfd54bf93
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
This seems to be a dupe of bug 1089615
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Resolution: --- → DUPLICATE
Duplicate of bug: 1089615
bug 1089615 was verified fixed on 11/13, but this bug is still occuring. Reopening this bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Duplicate of this bug: 1101251
(Reporter)

Comment 5

3 years ago
Please use this link to view video of the issue - http://youtu.be/YRhcljrKH8s
You need to log in before you can comment on or make changes to this bug.