Closed Bug 1091958 Opened 8 years ago Closed 8 years ago

url bar autocomplete list ignores protocol in input

Categories

(Firefox :: Address Bar, defect)

32 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: illumilor.e, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 2014092000

Steps to reproduce:

When typing things such as "http://mozilla" in the url bar, in the dropdown menu, it will include results such as "https:/mozilla" or "http://addons.mozilla" even though those do not match what was typed in the url bar.
Component: Untriaged → Location Bar
Summary: url drop down search menu ignores input → url bar autocomplete list ignores protocol in input
Duplicate of this bug: 1117562
yes, this is by design. there's no plan to change that for now cause it allows us to give more results to most users.
We could eventually evaluate a token filter to not do the ignore, but it would not benefit many users since those tokens are completely undiscoverable atm.

sorry, it's a wontfix for now, if we ever figure a way to make tokens discoverable, we could re-evaluate.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1117562
See Also: → 1276124
You need to log in before you can comment on or make changes to this bug.