Closed Bug 1091998 Opened 8 years ago Closed 8 years ago

wsj.com/video thinks that Firefox can't play HTML5 video

Categories

(Web Compatibility :: Desktop, defect)

x86
macOS
defect
Not set
normal

Tracking

(firefox33 affected, firefox34 affected, firefox35 affected, firefox36 affected)

RESOLVED WORKSFORME
Tracking Status
firefox33 --- affected
firefox34 --- affected
firefox35 --- affected
firefox36 --- affected

People

(Reporter: cpeterson, Unassigned)

References

()

Details

(Whiteboard: [contactready][clientsniff])

STR:
1. Disable the Flash plugin
2. Load http://www.wsj.com/video/

RESULT:
"Sorry, your browser does not appear to support HTML5 video playback. You will need the flash plugin installed to view this video."

I can reproduce this with Firefox 33 and Nightly 36 on OS X 10.10.

Is this a problem playing H.264 video or a bug in the website's video support detection?
Blocks: 1092008
I just ran into this, and it's an evangelism bug. Using User Agent Switcher to pretend to be IE 11 results in working HTML5 video. From their script:

            var is_firefox = navigator.userAgent.toLowerCase().indexOf('firefox') > -1;
...

            if(!canPlay || is_firefox){ // if firefox or cannot play, display message.
Thanks for debugging, Brian!
Component: Video/Audio → Desktop
Product: Core → Tech Evangelism
In a few different places in http://video-api.wsj.com/api-video/player/js/wsjvideo.min.js they're sniffing for "firefox" in the UA string to serve flash or show the "Sorry, your browser does not appear to support HTML5 video playback" message.

@Karl, can we reach out to them to ask why they think that? This may be related to not shipping mp4 playback on Mac in stable, but that's just a guess.
Whiteboard: [contactready][clientsniff]
Flags: needinfo?(kdubost)
See Also: → 980572
Duplicate of this bug: 1112579
Bug 1112579 was reported for Firefox for Android. Installing Flash on a phone is sort of impossible these days. :/
Summary: wsj.com/video thinks that Firefox can't play HTML5 video on OS X → wsj.com/video thinks that Firefox can't play HTML5 video
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.