[download] The file with 0 byte in size is created when a file is downloaded from Browser while no space left in internal storage.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: jackjangbugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: TD 610 [systemsfe])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141030030218

Steps to reproduce:

[Detail] 
The file with 0 byte in size, which is not displayed on browsing, is created when a file (an image around 10KB in size) is downloaded from Browser while no space left in internal storage. 

[Preparations] 
- Make the internal storage no space left. 

[Steps to Reproduce] 
1. Tap [Browser] icon on Home screen. 
2. Enter heavy image to [Search or enter address] field. 
3. Tap [Image] tab on the result screen. 
4. Tap any image (around 500KB). Touch and hold the image and tap [Save Image]. 



Actual results:

Downloading is completed and nothing is displayed when the image is opened. 


Expected results:

A warnig message such as ""No space left"" should be dispalyed and downloading fail.
(Reporter)

Updated

4 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
(Reporter)

Updated

4 years ago
Flags: needinfo?(dhylands)
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.0?
I'm sorry, I don't know what you're asking me for?
Flags: needinfo?(dhylands)
(Reporter)

Comment 3

4 years ago
I'm asking, Browser try to download content even though Internal or external storage is full.
That's why 0 byte(=means that download is successful) is stored on device, there is no memory in device. 

I guess free space is less than total byte of downloading contents, It should be stop download and process error such as memory is full.
Flags: needinfo?(ryang)
(Reporter)

Comment 4

4 years ago
This is operator issue
Whiteboard: TD 610
Hi Jackjang,

Would you please provide any debug log/logcat for our investigation ? Thanks !
Flags: needinfo?(ryang) → needinfo?(jackjangbugzilla)

Comment 6

4 years ago
Hi Alphan:
 Please help check this issue as well.

Thanks!!
Shawn
Flags: needinfo?(alchen)
Hi Jack,
the following is how BT handle this situation?
Could you take a look and see if it is good enough for you?

https://github.com/mozilla-b2g/gaia/blob/8701166b9864e2f369c022653826cd6da00e2e12/apps/system/js/bluetooth_transfer.js#L274
Flags: needinfo?(alchen)
Hi Ben,
could you take a look about this bug?
Do we have the check before download a file like BT in browser?
Flags: needinfo?(bfrancis)
need UX implementation. push to 2.2?
blocking-b2g: 2.0? → 2.2?
(Reporter)

Comment 10

4 years ago
hi, all
Repro step is easy.
1. Making Internal or external storage is full(only left about 300kb)
2. Try to download any image less than 300kb.
3. try to download same image many times and simultaneous.(maybe It will be download error with "SD card is full" after second times. It is normal behavior)
4. See settings-> downloads
you can see download list such as download success and download fail on download list window
5. Click any of download failed list or download succeed list
It is occurred that cant not open succeed of download's file or re-download done when download failed list, sometimes.

6. See UMS using settings-> USB storage 
There is many 0 byte files in download folder.

The problem is 
1. It will be removed succeed of download file if we will try to download many times even though storage is full 
2. It is remain 0 byte failed of download file on downloads folder.

This is operator issue and we want to get patch in 2.0
Flags: needinfo?(jackjangbugzilla) → needinfo?(ryang)
Hi Ben , per comment 8, could you please kindly provide your comments ? 
Thank you very much!!
Flags: needinfo?(ryang)
Hi Jenny, 

would you please kindly provide your comments on this from UX's perspective ?

Thank you very much!
Flags: needinfo?(jelee)

Comment 13

4 years ago
Hello, 
(In reply to Rachelle Yang [:ryang][ryang@mozilla.com] from comment #12)
> Hi Jenny, 
> 
> would you please kindly provide your comments on this from UX's perspective ?
> 
> Thank you very much!

Hello,
I will update related spec to address this issue, but the change won't be in scope of 2.2, thanks for understanding!
Flags: needinfo?(jelee)
If I understand correctly a download silently fails if the device is out of storage?

Aus, is this currently expected behaviour? Do we need to add a feature request to warn the user?
Component: Gaia::Browser → Gaia::System
Flags: needinfo?(bfrancis) → needinfo?(aus)

Comment 15

4 years ago
The expected behavior is that we tell the user that there is no more free space. This is the behavior that seems to be observed sometimes but other times not. It's possible that it's a bug in gecko that is failing to report the error properly.

I'll assign this to myself, but, I'm still dealing with other things at this time so I wouldn't expect too much movement on this before next week. :)
Assignee: nobody → aus
Flags: needinfo?(aus)
Whiteboard: TD 610 → TD 610 [systemsfe]

Comment 16

4 years ago
QA, could we verify to see what happens on 2.2 and 2.1 with the STRs in the description?
Keywords: qawanted
I was unable to reproduce this issue on 2.2 Flame KK or 2.1 Flame KK.  I did reproduce it on 2.0 Flame KK though.

Issue does NOT occur

Environmental Variables:
Device: Flame 2.2
BuildID: 20141119044505
Gaia: e64428c5b2dce5db90b75a5055077a04f4bd4819
Gecko: aa72ddfe9f93
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Environmental Variables:
Device: Flame 2.1
BuildID: 20141117201226
Gaia: 1b231b87aad384842dfc79614b2a9ca68a4b4ff3
Gecko: 95fbd7635152
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Issue DOES occur

Environmental Variables:
Device: Flame 2.0
BuildID: 20141118152123
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: faa64077b0c2
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted

Comment 18

4 years ago
:jackjang, is this still an issue for you guys? If so, could you please re-nominate for blocking 2.0 status? Thanks!
blocking-b2g: 2.2? → ---
Flags: needinfo?(jackjangbugzilla)

Comment 19

4 years ago
Confirmed as an issue on 2.0 *only*
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)

Updated

4 years ago
Blocks: 1141798

Updated

4 years ago
Assignee: aus → nobody

Comment 20

4 years ago
I haven't seen any response in a long time on this one and it's 2.0 only. I'm going to close it as WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Updated

3 years ago
Flags: needinfo?(jackjangbugzilla)
You need to log in before you can comment on or make changes to this bug.