[Flame][v2.1][Built-in Keyboard App & System Keyboard Mgmt]Press Period key behind inputting characters, then pess Delete key,the period key isn't reverted.

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: liuyong, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8514859 [details]
0445.MP4

[1.Description]:
Press Period key behind inputting characters, then pess Delete key,The period key isn't reverted.
Found time:4:45 AM
Attachments:logcat_0445.txt, 0445.mp4

[2.Testing Steps]: 
1. Launch Message.
2. Type in the characters "Sugg" ,then press the Period key (".") 
** The word "Dug." is entered 
3. Press the Delete key once .


[3.Expected Result]: 
3. The entered text should revert to "Sugg.".

[4.Actual Result]: 
3. The entered text reverts to "Sugg",not "Sugg.".

[5.Reproduction build]: 
Gaia-Rev        eb0aab0f13c78c7ac378ad860e865c4b6eaf669f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/318019f80a8e
Build-ID        20141029001202
Version         34.0

[6.Reproduction Frequency]: 
Always Recurrence,10/10
(Reporter)

Comment 1

4 years ago
Created attachment 8514860 [details]
logcat_0445.txt
I think this behavior is introduced by Bug 1053647.
Ni Omega to see if this is as expected.
Flags: needinfo?(ofeng)
Yes, it's introduced by bug 1053647. "Sugg" is expected.
Flags: needinfo?(ofeng)
Close this as invalid per comment 3, this is by design.

Omega, thanks.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Summary: [MGSEI][Flame][v2.1][Built-in Keyboard App & System Keyboard Mgmt]Press Period key behind inputting characters, then pess Delete key,the period key isn't reverted. → [Flame][v2.1][Built-in Keyboard App & System Keyboard Mgmt]Press Period key behind inputting characters, then pess Delete key,the period key isn't reverted.
You need to log in before you can comment on or make changes to this bug.