[FFOS2.0][Settings][Language]The font changed to unbold after set language as Greek.

VERIFIED FIXED in Firefox OS v2.0M

Status

Firefox OS
Gaia::Settings
P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: sync-1, Assigned: mwu)

Tracking

({polish})

unspecified
2.1 S8 (7Nov)
polish
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M+, b2g-v2.0 affected, b2g-v2.0M verified, b2g-v2.1 affected, b2g-v2.2 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created an attachment (id=992088)
 pic
 
 DEFECT DESCRIPTION:
 ->The font will change after set language as Greek.
 
 REPRODUCING PROCEDURES:
 ->Settings ->Language ->Change language as Greek---KO
 中文描述:
 将语言设为希腊语时,其他语言字体由加粗状态变成不加粗;
 将语言设为中文(其他非希腊语)时,其他语言字体变回原来的加粗状态。
 
 EXPECTED BEHAVIOR:
 ->The font won't change.
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 100%
 0752-2639344/61344
 
 For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Created attachment 8514883 [details]
pic

Updated

4 years ago
Blocks: 1054172, 1080481
status-b2g-v2.0M: --- → affected
Keywords: polish

Updated

4 years ago
Summary: [FFOS2.0][Settings][Language]The font will change after set language as Greek. → [FFOS2.0][Settings][Language]The font changed to unbold after set language as Greek.

Comment 2

4 years ago
Hi Evelyn, Hi Gary,
Though this is polish issue. Could you check whether we unbold the font after change language to Greek?
Thanks!
Flags: needinfo?(gchen)
Flags: needinfo?(ehung)

Updated

4 years ago
See Also: → bug 1092088

Comment 3

4 years ago
Maybe the applied font files are different because of language setting. It seems not a blocker, so put it in low priority queue.
Flags: needinfo?(gchen)
Flags: needinfo?(ehung)

Comment 4

4 years ago
Hi Chens,
Do you have any finding? Thanks!
Flags: needinfo?(shchen)
CSS properties for Greek and all the other languages are the same, I think it might be related to fonts but not sure about. Michael, do you have any ideas about this?
Flags: needinfo?(shchen) → needinfo?(mwu)
(Assignee)

Comment 6

4 years ago
This is working as intended - Fira before FFOS 2.1 did not have sufficiently good Greek support. For 2.1 and newer, we can consider switching the default font to Fira - I don't know if the Greek support with the newest Fira is considered sufficient. It's also possible to backport the new Fira with better Greek support to 2.0 if we really want this.
Flags: needinfo?(mwu)

Comment 7

4 years ago
Hi Peipei,
Can you check whether 2.1/2.2 with new Fira font still have this problem? Thanks!
Flags: needinfo?(pcheng)

Updated

4 years ago
Duplicate of this bug: 1092088
(Assignee)

Comment 9

4 years ago
2.1/2.2 still use different fonts for Greek. However, we may be able to switch 2.1/2.2 to Fira for Greek.
(Assignee)

Comment 10

4 years ago
Created attachment 8518306 [details] [diff] [review]
Set Fira as the default font for Greek

Can we switch over with the new Fira?
Assignee: nobody → mwu
Attachment #8518306 - Flags: ui-review?(padamczyk)
Attachment #8518306 - Flags: review?(jfkthame)
I suspect the rendering of Roboto (which is used as default when Greek is selected) is excessively thin when it appears as light-on-dark, but would be OK in a dark-on-light context; it's a TrueType font, and depending on the rasterizer and hinting/antialiasing settings, this can sometimes be a problem.

That doesn't help fix things, but just noting that the issue is likely to be much less noticeable in other contexts, depending on styling.

As for switching to use Fira for Greek: I think we should go ahead, but let's see what Patryk thinks.
Attachment #8518306 - Flags: review?(jfkthame) → review+

Updated

4 years ago
blocking-b2g: --- → 2.0M+
Comment on attachment 8518306 [details] [diff] [review]
Set Fira as the default font for Greek

Let's make the switch.
Attachment #8518306 - Flags: ui-review?(padamczyk) → ui-review+
(Assignee)

Comment 14

4 years ago
In order to backport this to 2.0m, two other bugs must also be backported to 2.0m - bug 987872 and bug 1032659 . If you want this bug to block 2.0m, please also set those other two bugs to block 2.0m.
blocking-b2g: 2.0M+ → 2.0M?
https://hg.mozilla.org/mozilla-central/rev/cdbaa127d3b2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S8 (7Nov)
(In reply to Josh Cheng [:josh] from comment #7)
> Hi Peipei,
> Can you check whether 2.1/2.2 with new Fira font still have this problem?
> Thanks!

I see the same behavior on Flame 2.0/2.1/2.2
status-b2g-v2.0: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Flags: needinfo?(pcheng)
(Assignee)

Updated

4 years ago
status-b2g-v2.2: affected → fixed

Comment 17

4 years ago
(In reply to Peipei Cheng from comment #16)
> (In reply to Josh Cheng [:josh] from comment #7)
> > Hi Peipei,
> > Can you check whether 2.1/2.2 with new Fira font still have this problem?
> > Thanks!
> 
> I see the same behavior on Flame 2.0/2.1/2.2

Hi Peipei,
According to comment 15. the bug should be fixed in 2.2. Can you retest this on 2.2 and also capture picture which we can decide whether to land it back to 2.0M?
Thanks!
Flags: needinfo?(pcheng)

Updated

4 years ago
blocking-b2g: 2.0M? → 2.0M+
(Assignee)

Comment 18

4 years ago
Josh, please read comment 14.
blocking-b2g: 2.0M+ → 2.0M?

Comment 19

4 years ago
(In reply to Michael Wu [:mwu] from comment #14)
> In order to backport this to 2.0m, two other bugs must also be backported to
> 2.0m - bug 987872 and bug 1032659 . If you want this bug to block 2.0m,
> please also set those other two bugs to block 2.0m.

Triage:
Hi Michael, I have marked bug 987872 and bug 1032659 to 2.0M+. Thanks for the help!
blocking-b2g: 2.0M? → 2.0M+
Flags: needinfo?(mwu)
Josh, comment 16 is to answer your question in comment 7. And I tested on an earlier build 20141103040202, so I can still this issue on that build.

I tested on today's build and the font will not change bold after i change language to greek.

Gaia-Rev        5ae28ff11b982e2bd7d1aa097cda131536952bdc
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/a926116946f8
Build-ID        20141111160205
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141111.192537
FW-Date         Tue Nov 11 19:25:48 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(pcheng)
(Assignee)

Updated

4 years ago
Flags: needinfo?(mwu)
(Assignee)

Updated

4 years ago
Blocks: 1098133
Uplift to v2.0m got conflicts.
Flags: needinfo?(mwu)
Keywords: branch-patch-needed

Updated

4 years ago
See Also: → bug 987872
(Assignee)

Comment 22

4 years ago
Created attachment 8522755 [details] [diff] [review]
Set Fira as the default font for Greek (v2.0m)
Flags: needinfo?(mwu)
(Assignee)

Updated

4 years ago
Keywords: branch-patch-needed

Comment 24

4 years ago
Hi Hubert,
As we discussed yesterday. Please build multi-lingual version for verification. Thanks!
Flags: needinfo?(hlu)
(In reply to Josh Cheng [:josh] from comment #24)
> Hi Hubert,
> As we discussed yesterday. Please build multi-lingual version for
> verification. Thanks!

This issue could not be found on woodduck 2.0m.

== Build Information ==
Gaia-Rev        cc690f8016b672475dc186bc7fd58aef45e684b7
Gecko-Rev       03d3ab62d5b07b915434f2d1d68495ad5915ecd2
Build-ID        20141118184148
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1416306679
FW-Date         Tue Nov 18 18:31:44 CST 2014
Flags: needinfo?(hlu)
Status: RESOLVED → VERIFIED
status-b2g-v2.0M: fixed → verified
status-b2g-v2.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.