If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Flame][v2.1][Message]The latest message you just sent from Dialer app will not show after you launch Message.

RESOLVED INVALID

Status

Firefox OS
Gaia::SMS
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Alissa(leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
The latest message you just sent from Dialer app will  not show after you launch Message.
Occurence time:15:53
see attachments:logcat1.txt,VIDEO0043_Compress.MP4
[2.Testing Steps]: 
Prerequisite: Two contacts saved on the device. 

1. Open the Messages app. 
2. Send a message to contact "A". 
3. Press the home button. 
4. Open the dialer and then tap on the "Contacts" symbol at the bottom of the screen. 
5. Tap on a different contact. Contact "B". 
6. Tap on the "SMS" icon to message them. 
7. Send contact "B" a message. 
8. Tap the "Home" button and tap on the "SMS" app. 
9. Look closely at the message thread to contact "B". 


[3.Expected Result]: 
9. Ensure the only message seen is the one that was sent to contact "B" and not the message sent to contact "A".  

[4.Actual Result]: 
Message to contact A will be displayed.

[5.Reproduction build]: 
Gaia-Rev        0e332da37ad3d12faa78bc0d20d95735e3b5194d
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/13555d9de4db
Build-ID        20141030161200
Version         34.0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
(Reporter)

Comment 1

3 years ago
Created attachment 8514872 [details]
logcat1.txt
(Reporter)

Comment 2

3 years ago
Created attachment 8514876 [details]
VIDEO0043_Compress.MP4
Hey Alissa, I just want to understand your description.

* After step 7, you're in the thread for contact B ("Aaron Cook" in the video)
* After step 9, you're in the thread for contact A ("ABC" in the video)
* both threads look correct.

Step 6 and 7 are happening in an "inline" activity, that means a separate window for the application. That's why in step 9 you see the thread from step 2.
However, if you open the Dialer app again, you'll likely see the window from step 7, because the activity is still active.

The idea is that, from the user point of view, the activity is really part of the Dialer window.

From this explanations, I don't see any unexpected behavior in the video. Can you outline what is wrong in your opinion?

If you disagree with this UX, we can ask from our UX designers.
Flags: needinfo?(huayu.li)
(Reporter)

Comment 4

3 years ago
This issue come from a testcase:13310
Initial Condition:  Message threads appear correctly when sending message to different contacts from different apps.

Prerequisite: Two contacts saved on the device. 

Please see this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=974733  
TC Procedure:  1. Open the Messages app. 
2. Send a message to contact "A". 
3. Press the home button. 
4. Open the dialer and then tap on the "Contacts" symbol at the bottom of the screen. 
5. Tap on a different contact. Contact "B". 
6. Tap on the "SMS" icon to message them. 
7. Send contact "B" a message. 
8. Tap the "Home" button and tap on the "SMS" app. 
9. Look closely at the message thread to contact "B". 
>> Ensure the only message seen is the one that was sent to contact "B" and not the message sent to contact "A".  
Please check this case,if the design changed,we will mark this case as invalid.
Flags: needinfo?(huayu.li)
Hey Eric, I think the testcase is slightly wrong here. At last step we should really see the thread for contact "A" (header _and_ messages for contact "A"). Can you please have a look?
Flags: needinfo?(echang)
The test case is from bug 974733, and it is to address an issue that the message and the recipient is not paired up correctly, right?
If yes, I think we need to modify the test case verification part to make it more understandable. Adding an extra step 8.5, such as "Tap x to dismiss current message to A, and go to conversation to B"

https://moztrap.mozilla.org/manage/cases/?&pagenumber=1&pagesize=100&sortfield=created_on&sortdirection=desc&filter-id=13310
https://bugzilla.mozilla.org/show_bug.cgi?id=974733
Flags: needinfo?(echang)
(Reporter)

Comment 7

3 years ago
OK,we will check the TC agian.
I think that in bug 974733, the issue was that we were moving to contact B in both the activity and the main Messages window. So to check that the issue is resolved, we need to check that we're in contact B in the activity, and in contact A (I mean: _not_ in contact B) in the main window.
(Reporter)

Updated

3 years ago
Summary: [MGSEI][Flame][v2.1][Message]The latest message you just sent from Dialer app will not show after you launch Message. → [Flame][v2.1][Message]The latest message you just sent from Dialer app will not show after you launch Message.
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.