Bad feedback when clicking on twisties (disclosure triangles)

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
17 years ago
10 years ago

People

(Reporter: mpt, Assigned: andreww)

Tracking

({classic})

Trunk
mozilla1.0.1
PowerPC
Mac System 9.x
classic

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Build: 2001110708, Mac OS 9.1, Classic theme

To reproduce:
1.  Open the Preferences dialog.
2.  Mouse down on the expander triangle for a collapsed category branch.
3.  Once you have seen what happens, mouse up to expand the branch.
4.  Mouse down on the expander triangle for an expanded category branch.
5.  Once you have seen what happens, mouse up to collapse the branch.

What you should see:
2.  The triangle goes dark.
3.  The triangle goes light again, then it is replaced by its rotated version,
    then the branch expands.
4.  The triangle goes dark.
5.  The triangle goes light again, then it is replaced by its rotated version,
    then the branch expands.

What you actually see:
2.  The triangle disappears completely (!). (Note that this doesn't happen if
    the row is also selected.)
3.  The branch expands, then the triangle is replaced by its rotated version.
4.  Nothing happens.
5.  The branch expands, then the triangle is replaced by its rotated version.
(Reporter)

Comment 1

17 years ago
--> andreww
Assignee: hewitt → andreww
Keywords: classic
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED

Comment 2

17 years ago
Created attachment 58986 [details] [diff] [review]
Patch to make trees behave

Conveniently, the needed images are already being shipped--the attached patch
makes use of them.  Unfortunately, the image at

http://lxr.mozilla.org/mozilla/source/themes/classic/global/mac/twisty-closed-active.gif


appears to be corrupted, causing the disappearing triangle mpt mentions.  I'll
attach a replacement.  Based on

news://news.mozilla.org:119/3BB8F5B0.8040605@netscape.com

it looks like this cannot be fixed at the theme level for outliners :(.  Patch
also removes a couple of apparently unnecessary "text-decoration:none" rules
that were removed from win classic a while back.

Finally, I believe that twisty-open-selected.gif and twisty-closed-selected.gif
can simply be removed (don't have a full build system so I'd rather not mess
with jar files).  They aren't used anywhere else and are visually identical to
twisty-open.gif and twisty-closed.gif.

Comment 3

17 years ago
Created attachment 58987 [details]
Replacement for twisty-closed-active.gif
(Assignee)

Comment 4

17 years ago
thanks for the patches Ill take a look at em  .
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.9.8
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.8 → ---
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla1.0.1
any news about these old bitrotting patches?

Comment 6

15 years ago
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Comment 7

15 years ago
mac classic is no longer supported by mozilla.org and the mentioned file in the
patch does no longer exist in the cvs repository.
-> WONTFIX
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Updated

15 years ago
Attachment #58986 - Flags: review?(neil.parkwaycc.co.uk)

Comment 8

15 years ago
Comment on attachment 58986 [details] [diff] [review]
Patch to make trees behave

Sorry, I can't review a mac-specific patch, please ask a mac user.
Attachment #58986 - Flags: review?(neil.parkwaycc.co.uk)
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.