Closed Bug 1092133 Opened 7 years ago Closed 7 years ago

[pointer-events] TEST-UNEXPECTED-FAIL | APZCBasicTester.PanningTransformNotifications

Categories

(Core :: Panning and Zooming, defect)

All
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1092128

People

(Reporter: alessarik, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140825202822

Steps to reproduce:

Gtest with enabled pointer events on m-c


Actual results:

Actual function call count doesn't match EXPECT_CALL(check, Call("Complex pan"))...
Actual function call count doesn't match EXPECT_CALL(check, Call("Done"))...
Actual function call count doesn't match EXPECT_CALL(*mcc, NotifyAPZStateChange(_,GeckoContentController::APZStateChange::StartTouch,_))...
Actual function call count doesn't match EXPECT_CALL(*mcc, NotifyAPZStateChange(_,GeckoContentController::APZStateChange::TransformBegin,_))...
Actual function call count doesn't match EXPECT_CALL(*mcc, NotifyAPZStateChange(_,GeckoContentController::APZStateChange::StartPanning,_))...
Actual function call count doesn't match EXPECT_CALL(*mcc, NotifyAPZStateChange(_,GeckoContentController::APZStateChange::EndTouch,_))...
Actual function call count doesn't match EXPECT_CALL(*mcc, NotifyAPZStateChange(_,GeckoContentController::APZStateChange::TransformEnd,_))...
Actual function call count doesn't match EXPECT_CALL(*mcc, NotifyAPZStateChange(_,GeckoContentController::APZStateChange::StartTouch,_))...
Actual function call count doesn't match EXPECT_CALL(*mcc, NotifyAPZStateChange(_,GeckoContentController::APZStateChange::TransformBegin,_))...
Actual function call count doesn't match EXPECT_CALL(*mcc, NotifyAPZStateChange(_,GeckoContentController::APZStateChange::StartPanning,_))...
Actual function call count doesn't match EXPECT_CALL(*mcc, NotifyAPZStateChange(_,GeckoContentController::APZStateChange::EndTouch,_))...
Actual function call count doesn't match EXPECT_CALL(*mcc, NotifyAPZStateChange(_,GeckoContentController::APZStateChange::TransformEnd,_))...


Expected results:

Test should be passed
https://tbpl.mozilla.org/?tree=Try&rev=7f10eaf01724
Blocks: 1042108
OS: Windows 8 → All
Hardware: x86_64 → All
Component: Untriaged → Panning and Zooming
Product: Firefox → Core
OS: All → Windows 8.1
Summary: TEST-UNEXPECTED-FAIL | APZCBasicTester.PanningTransformNotifications → [pointer-events] TEST-UNEXPECTED-FAIL | APZCBasicTester.PanningTransformNotifications
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1092128
You need to log in before you can comment on or make changes to this bug.