[email/backend] Seeing intermittent Travis test-failures because of high IndexedDB / I/O latency

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
10 months ago

People

(Reporter: asuth, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
https://travis-ci.org/mozilla-b2g/gaia-email-libs-and-more/builds/39628154 just had 2 failures that are both due to our IndexedDB requests not being serviced in a timely fashion.  (Currently we freak out after 1 second by default, although steps involving messages will usually have their defaults boosted.)

The only tractable workaround is to bump the default test step timeout up from 1 second for Travis.

From IRC my analysis:
03:14:20 PM - asuth: in the "just auth" case we don't get the IndexedDB configCrated event until 1698.2 ms
03:14:55 PM - asuth: in the MIME hierarchies one, saveAccountState is starting at 741.2ms and never actually finishing before we tear the process down shortly after 1737.0ms
(Reporter)

Comment 1

4 years ago
gah, just saw 2 more failed test cases that seem attributable to IndexedDB commit jank.

Comment 2

2 years ago
Closing all intermittent test failures for Firefox OS (since we're not focusing on it anymore).

Please reopen if my search included your bug by mistake.

Comment 3

10 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.