Closed Bug 1092329 Opened 5 years ago Closed 4 years ago

[Homescreen] Modifying Homescreen settings via Hold-Tap menu at home shows Inaccurate UI

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: onelson, Unassigned)

References

Details

(Whiteboard: [2.1-Daily-Testing][systemsfe])

Attachments

(1 file)

Description:
When the user attempts to modify their homescreen settings from the homescreen [accessed via holding a tap on a divider/empty-space on the homescreen; select 'Homescreen Settings'], they will observe some inaccurate UI populate momentarily. The UI that will display is shared from the 'Settings' page and shows a smaller selection box displaying the information to change before changing to the default UI. During this step the UI is also displaying the default information for the UI [default setting is 'Three Columns'], regardless to if the user has changed to 'Four Columns'. This also reverts to the accurate information after a moment.
Worth noting that this issue does not occur if the user attempts to modify their 'Homescreen Settings' via the option found in the Settings menu.   
This issue was observed in 2.2 with the above symptons. In 2.1, video also provided, by following the repro steps will encounter a different UI disturbance that is still disorienting to the user. It also does not occur when attempting to change the 'Homescreen Settings' via the option in the 'Settings' menu.

Repro Steps:
1) Update a Flame device to BuildID: 20141031061804
2) Hold tap on homescreen divider/empty-space.
3) Select 'Homescreen Settings'.
4) Observe UI as it populates.
5) Change to 'Four Columns'; return to homescreen.
6) Repeat steps 2-4.
  
Actual:
UI populates with inaccurate information and sizing before resizing and assuming accurate information.
  
Expected: 
UI displayed for Homescreen settings is accurate and displayed accurately.


*******************************************  
Environmental Variables:
-------------------------------------------
Device: Flame 2.2 Master
BuildID: 20141031061804
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 6bd2071b373f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1
BuildID: 20141031001201
Gaia: f89c7b12c36572262c9ea76058694a139b1a8634
Gecko: 50d48f8a04c7
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-------------------------------------------
  
Repro frequency: 10/10
See attached:
video
* 2.2: http://youtu.be/z1CI7Dz87SI
* 2.1: http://youtu.be/cp-kHLwPBFg
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: [2.1-Daily-Testing]
This looks bad but it is only for a half a second and then it corrects itself. Not nominating to block on this.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Whiteboard: [2.1-Daily-Testing] → [2.1-Daily-Testing][systemsfe]
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.