Emacs keybindings for Chatzilla

RESOLVED DUPLICATE of bug 115204

Status

--
enhancement
RESOLVED DUPLICATE of bug 115204
17 years ago
12 years ago

People

(Reporter: matt, Assigned: rginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I'd like an optional Emacs like keybindings for Chatzilla, at least for
navigating the history list: Ctrl-P for previous command, Ctrl-N for next
command, Ctrl-B equals back-arrow, and so on.

Comment 1

17 years ago
Remove myself from QA of 33 open Chatzilla bugs and change to default QA
contact, since I have no way to verify these easily.  Still no working Mozilla
on my primary platform and it doesn't look like it will happen anytime soon. :(
QA Contact: mozilla → samuel

Updated

16 years ago
Summary: [RFE] Emacs keybindings for Chatzilla → Emacs keybindings for Chatzilla
Product: Core → Other Applications

Comment 2

14 years ago
I don't think this is such a good idea. For one, the Ctrl-P shortcut is
currently in use for Printing, and Ctrl-N may become used for opening new
windows etc. 

If you really want this functionality, I guess you could make it a plugin. But I
doubt a great lot of the users would use this.

Comment 3

14 years ago
While I would not want Emacs keybindings anywhere near my ChatZilla, I believe
most people would like to be able to re-configure the keybindings in general. An
Emacs keyset would just be one use of such a feature.

Comment 4

12 years ago

*** This bug has been marked as a duplicate of 115204 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.