(App-grouping) Make expand/collapse animation consistent

RESOLVED DUPLICATE of bug 927349

Status

defect
RESOLVED DUPLICATE of bug 927349
5 years ago
5 years ago

People

(Reporter: msandberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Steps to reproduce

1. Expand / collapse a small group (3 icons or so)
2. Notice the animation shown. Icons shrink and move to their new positions.
3. Expand / collapse a big group (8+ icons).
4. Notice the lack of animation. I'm guessing this is either due to the platform dependency or something similar. 

If we can't get the bigger group animations to work that's fine with me, but then we should consider removing the animations all together for collapse/expand. Right now it feels inconsistent that there sometimes is an animation and sometimes not.
This depends on bug 927349 and bug 1077169 - the animations can work fine, and do work fine when applying the WIP patch in bug 927349. The frame-rate of the animation for very large groups (> 12 icons, let's say) could be improved, and that's what I'm tracking in bug 1077169.
Depends on: 927349, 1077169
Blocks: app-grouping
No longer blocks: 1069701
This is really a duplicate, it isn't serving anyone to have an open bug for this, as the bug it's a duplicate of already blocks app-grouping. Marking as such.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 927349
You need to log in before you can comment on or make changes to this bug.