If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Calendar] When the Calendar app is launched there is graphical flashing underneath the month and year bar at the top.

RESOLVED INVALID

Status

Firefox OS
Gaia::Calendar
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Johnt, Unassigned)

Tracking

unspecified
x86
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-exploratory-3])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8515334 [details]
HIghlighted in Red.png

Description:
When the user launches the calendar app towards the top of the screen there is graphical flashing underneath the month and year.

Prereq: Calendar is not previously running in the background.

Repro Steps:
1) Update a Flame device to BuildID: 20141029001202
2) Launch Calendar App
3) Observe graphical behaviour at the top of the screen below the Month and Year bar.

Actual:
No graphical errors will occur when launching app.

Expected:
It is expected that no graphical errors will occur when launching the calendar app.

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031001201
Gaia: f89c7b12c36572262c9ea76058694a139b1a8634
Gecko: 50d48f8a04c7
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 6/8
See attached: Logcat, Screenshot
Flags: needinfo?(jmitchell)
(Reporter)

Comment 1

3 years ago
Created attachment 8515336 [details]
logcat_20141031_1532.txt
(Reporter)

Comment 2

3 years ago
This issues does NOT occur on the Flame 2.2 KK (319mb)

Result: No graphical error occurs under the Year and Date bar in calendar.

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031061804
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 6bd2071b373f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

------------------------------------------------------------

This issues DOES occur on the Flame 2.0 KK (319mb)

Result: Graphical error occurs under the Year and Date bar in calendar.

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031000201
Gaia: 7b8df9941700c1f6d6d51ff464f0c8ae32008cd2
Gecko: 82a6ed695964
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
NI to Calendar owner for blocking decision
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(edchen)

Comment 4

3 years ago
This is progress bar when calendar is sync with server, I thought that not a bug.
Flags: needinfo?(edchen)
works as expected. this is the "progress bar" (aka. "activity bar"), we display it every time the calendar app is syncing or processing the events. there is even a plan to change the color to blue to make it easier to see (Bug 1035639)

on 2.2 you're not seeing it because we only trigger a sync if there are other calendars besides the offline calendar.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.