Camera doesn't start with debug gecko

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: gwagner, Assigned: mikeh)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
On current b-i trunk I can't start the camera on the flame with a debug gecko.

F/MOZ_Assert( 2246): Assertion failure: false (MOZ_ASSERT_UNREACHABLE: Unanticipated camera mode in SetConfigurationInternal()), at ../../../dom/camera/GonkCameraControl.cpp:244
F/libc    ( 2246): Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1), thread 2265 (CameraThread)
(Reporter)

Updated

4 years ago
Flags: needinfo?(mhabicher)
(Reporter)

Comment 1

4 years ago
Maybe caused by 1090501?
(Reporter)

Comment 2

4 years ago
Camera works with rev a264cdd47217 so caused by 1090501
Blocks: 1090501
Thanks for finding this. Sorry about the inconvenience. I'll land a fix shortly.
Assignee: nobody → mhabicher
Flags: needinfo?(mhabicher)
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Created attachment 8516244 [details] [diff] [review]
Bug 1090501 patch to test

Gregor, do you have any specific STR to reproduce this crash?

I have the attached patch applied to my tree, and don't see any crashes in DEBUG mode (without or without B2G_NOOPT defined).
Attachment #8516244 - Flags: feedback?(anygregor)
(I asked aosmond to try this patch as well, and he isn't seeing the crash either.)
Spoke with gwagner on IRC, and this issue isn't happening any more.

If this issue rears its ugly head again, please reopen.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

4 years ago
Attachment #8516244 - Flags: feedback?(anygregor)
You need to log in before you can comment on or make changes to this bug.