rdf files do not get loaded off of a ufs partition.

VERIFIED DUPLICATE of bug 86538

Status

()

Core
XPCOM
VERIFIED DUPLICATE of bug 86538
16 years ago
16 years ago

People

(Reporter: nnooiissee, Assigned: Conrad Carlen (not reading bugmail))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
yes, i know mozilla will not run off of a ufs partition, but i have Mozilla.app
on a hfs+ partition, but /Users is on ufs. mozilla runs, and even loads prefs,
but from what i can tell not .rdf files get loaded. this means each time i run
the window, side bar, tool bars, etc are back to their default positions. this
is very annoying.

a couple of quotes from the java script console:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED) [nsIRDFService.GetDataSource]" 
nsresult: "0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED)"  location: "JS frame ::
chrome://navigator/content/sessionHistoryUI.js :: <TOP_LEVEL> :: line 46"  data: no]

Error: [Exception... "Component returned failure code: 0x80520001
(NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIRDFService.GetDataSource]"  nsresult:
"0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame ::
chrome://navigator/content/urlbarBindings.xml#autocomplete-result-popup.updateEngines()
:: updateEngines :: line 3"  data: no]
Source File:
chrome://navigator/content/urlbarBindings.xml#autocomplete-result-popup.updateEngines()
Line: 3

so many components...guessing.
(Assignee)

Comment 1

16 years ago
We might say that mozilla will not run off a UFS partition. We should say that
it will not run if installed on a UFS partition *or* if the /Users dir is on a
UFS partition. Since it still comes down to the problem of UFS, changing
component and making dup of bug 86538 

*** This bug has been marked as a duplicate of 86538 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Component: Profile Manager BackEnd → XPCOM
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Verified as a duplicate of 86538
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.