Closed Bug 1092471 Opened 5 years ago Closed 5 years ago

Username capitalised when entering in bank logon screen

Categories

(Firefox for Android :: Keyboards and IME, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 37
Tracking Status
firefox36 --- affected
firefox37 --- verified
fennec + ---

People

(Reporter: mrmcallum, Assigned: manu.jain13, Mentored)

Details

(Whiteboard: [lang=java][good first bug])

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Linux; U; Android 4.4.2; en-nz; GT-P5210 Build/KOT49H) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Safari/534.30

Steps to reproduce:

Goto www.asbbank.co.nz
Tap username
Start entering a lowercase unsername



Actual results:

'mrmcallum' becomes 'Mrmcallum'


Expected results:

'mrmcallum' should have been entered
We autocapitalize by default for use in inputs (bug 871884 iirc) for when people write sentences. I believe GeckoInputConnection.java has the logic for auto-capitalizing by default. Re-evaluate?
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Component: Logins, Passwords and Form Fill → Keyboards and IME
Ever confirmed: true
OS: Linux → Android
Hardware: Other → ARM
Drive by:

Are we referring in this site:
https://www.dropbox.com/s/chfv96gc1gjxjex/bug1092471.png?dl=0

To the "Enter your access code" field? (ie: "username"?)

I think this may be your keyboard setting ... Google keyboard (and the one I use: SwiftKey) have IME settings for auto-cap at word start.

Google KBD has Settings -> Preferences -> Auto-capitalization
SwiftKey KBD has Settings -> Advanced -> Auto Capitalize
The HTML5 way to turn this off is via the "inputmode='verbatim'" attribute on the field. Safari also supports a non-standard "autocapitalize" attribute. I don't see either of those specified here. Do we want to introduce logic to try to guess what behavior the site wants?
(In reply to Mark Capella [:capella] from comment #2)
> Drive by:
> 
> Are we referring in this site:
> https://www.dropbox.com/s/chfv96gc1gjxjex/bug1092471.png?dl=0
> 
> To the "Enter your access code" field? (ie: "username"?)
> 
> I think this may be your keyboard setting ... Google keyboard (and the one I
> use: SwiftKey) have IME settings for auto-cap at word start.
> 
> Google KBD has Settings -> Preferences -> Auto-capitalization
> SwiftKey KBD has Settings -> Advanced -> Auto Capitalize

Different form in the mobile version (looks like the desktop site on your tablet).
This is the mobile version I see:
https://www.dropbox.com/s/tp1z9519in3puxw/bug1092471Phone.png?dl=0

In the <input> |Access Code|, Auto-capitalization preference as set by the keyboard IME for Google and/or Swift Keyboard dictates the behaviour as I observe it.
Lets turn off autocap for input[type="text"] at least. We can leave it on for textfield.
Mentor: nchen
tracking-fennec: ? → +
It doesn't happen when I use Google Chrome to enter my bank username.
Whiteboard: [lang=java]
This looks like a good first bug if Comment 6 is the accepted approach. Is there consensus there?
(In reply to Mike Hoye [:mhoye] from comment #8)
> This looks like a good first bug if Comment 6 is the accepted approach. Is
> there consensus there?

Sure.
Rock and roll.
Whiteboard: [lang=java] → [lang=java][good first bug]
I wish to start working on this bug.
Hello, Aniket, and welcome aboard. 

It takes a little bit of work to get set up to build Firefox for Android. You'll be able to get set up by following the instructions here: 

https://wiki.mozilla.org/Mobile/Fennec/Android 

There's a lot there, but don't let that put you off. Once you've got your environment set up, let us know here in the bug, and we'll point you towards the next steps.
Hi Mike,

I have already set up fennec build on my local and installed in on my android device. Do guide me with further steps.
Hey, awesome! 

OK, the mentor for this bug is Jim Chen. If you have questions for how to proceed, you can ask him via the "need more information" checkbox just below the comments here. For now, let's get you started off in the right place: Jim, can you provide us with a source/DXR link for Aniket?
My suggestion is to make lowercase a default option instead of auto-capitalisation. When a user wants auto-capitalisation he can do it manually as in other browsers.
Hi,
    Can I know where is the relevant code where I can get started. Also please confirm if turning off autocap for input[type="text"] is appropriate solution for this.
Attached patch bug1092471.patch (obsolete) — Splinter Review
patch created.
Attachment #8531640 - Flags: review?(nchen)
So this is how it works around here? Someone expresses an interest to solve a bug and wait for appropriate inputs and anyone can come and directly provide a patch. How do beginner level interested candidates get started ? This is just plain sad :(
(In reply to Aniket Thakur from comment #18)
> So this is how it works around here? Someone expresses an interest to solve
> a bug and wait for appropriate inputs and anyone can come and directly
> provide a patch. How do beginner level interested candidates get started ?
> This is just plain sad :(

Hi Aniket, sorry about what happened :( Manu is a relatively new contributor just like you, and it looks like both of you were working on this bug at the same time by accident. Usually we avoid conflicts like this by using the "Assigned To" field and set the bug status to "ASSIGNED". For example, if you want to work on this bug, you would assign the bug to yourself (or ask someone to assign the bug to you). This way it's clear to everyone who is working on the bug.

I'm assigning this bug to Manu because he already has a patch, but please find another one here, http://www.joshmatthews.net/bugsahoy/?mobile=1  There are many options and you can pick one that hasn't been assigned yet. Thanks for your understanding!
Assignee: nobody → manu.jain13
Status: NEW → ASSIGNED
Comment on attachment 8531640 [details] [diff] [review]
bug1092471.patch

Review of attachment 8531640 [details] [diff] [review]:
-----------------------------------------------------------------

Almost there! Can you change it so we use lowercase mode only for "text" fields?

Basically like this:
If mIMETypeHint is "text", set autocapitalized mode if mIMEModeHint is "autocapitalized" (no hyphen).
Otherwise, set autocapitalized mode if mIMEModeHint is not "lowercase"
Attachment #8531640 - Flags: review?(nchen) → feedback+
Sorry Aniket about what has happened. I thought this bug was free as there was no assignee mentioned. It was a misunderstanding.
Changes made as told.
Attachment #8531640 - Attachment is obsolete: true
Attachment #8531990 - Flags: review?(nchen)
Comment on attachment 8531990 [details] [diff] [review]
bug_1092471_v2.patch

Review of attachment 8531990 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, Manu! Thanks! Sorry for the late response.
Attachment #8531990 - Flags: review?(nchen) → review+
https://hg.mozilla.org/integration/fx-team/rev/e420c7eb91f6
Keywords: checkin-needed
Whiteboard: [lang=java][good first bug] → [lang=java][good first bug][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/e420c7eb91f6
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [lang=java][good first bug][fixed-in-fx-team] → [lang=java][good first bug]
Target Milestone: --- → Firefox 37
Verified as fixed in Firefox for Android 37.0a1 (2015-01-11)
Device: Samsung Galaxy S4 (Android 4.4.2)
You need to log in before you can comment on or make changes to this bug.