Automatic re-load of web-page (when a frame dynamically resized with JavaScript)

RESOLVED DUPLICATE of bug 48422

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 48422
17 years ago
16 years ago

People

(Reporter: Erik, Assigned: Marc Attinasi)

Tracking

({testcase, top100})

Trunk
Future
x86
Windows NT
testcase, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Environment:
==============
OS: Win NT 4.0 SP-5
Mozilla BuildID:    2001101117



Summary:
=========
Every page is automatically re-loaded on www.t-online.de and all subsequent sites...

Reproducible: yes


Steps to Reproduce:
====================
1. start navigator

2. make sure browser is maximized (don't know if this is _really_ necessary -
see notes below)

3. enter "http://www.t-online.de" in location bar


Actual Results:  
================
After finally finishing the display of the site navigator clears the window and
re-starts downloading the page!


Expected Results:  
==================
Page is loaded only once!


Additional Information:
========================

- if error doesn't occur on the front-page then click a menu-item in the left
frame, e.g. "Nachrichten"

- problem seems to occur on every page within t-online.de domain

- I had one case where the page has been loaded only once when the
browser-window was not in state "maximized" - but this was only once out of 30
or 40 tries. 


Note:
======
With IE 5.5 and Netscape 4.51 everything works fine!

Comment 1

17 years ago
Confirmed after clicking "Nachrichten", 2001101914, WinXP.

Comment 2

17 years ago
reproduced on
Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5) Gecko/20011011
Same as RC after clicking on "Nachrichten"


(Reporter)

Comment 3

17 years ago
Today the problem didn't occur - perhaps they changed something on their page?
Can someone else pse check this out before I mark this bug as "worksforme"? TIA,
Erik
(Reporter)

Comment 4

17 years ago
Sorry - problem _still_ persist... Don't know, why it worked fine this morning...
wfm with win2k with a 6h old CVS build
confirming if I click on "Nachrichten" at the left side

-> Layout ?
Assignee: asa → attinasi
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen
*** Bug 111179 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
in my duplicate, i forgot to enter the build ID: 2001112009. The "show images"
menu entry is greyed out. It occured on W2k, SP 1 (5.00.2195). Hardware
is intel PIII@650, 256M RAM, 1024*768
HTH, Alex

Updated

17 years ago
Target Milestone: --- → Future
*** Bug 133086 has been marked as a duplicate of this bug. ***
Keywords: mozilla1.0.1, top100

Comment 10

17 years ago
From my comment in bug 133086:

I see this on W2K 2002032203 - the page renders as it loads, then once it's all
loaded, all frames blank out and re-render.

Further investigation reveals this in the outermost frameset:
<frameset rows="73,*" ... onLoad="if(document.getElementById)
{top.document.getElementById('frameset1').rows='65,*'} else if(document.all)
{top.document.all.frameset1.rows='65,*'}">

So, if the browser supports document.getElementById or document.all, the top
frame is shrunk by 8px (although why you'd want to do this is beyond me!). This
causes all the frames to re-render (my proxy server shows the pages being
re-requested from the server too!).

I would expect that Mozilla should be able to reflow the contents of the frames
when they change size without re-rendering them entirely. It shouldn't need to
re-fetch them either - there is nothing that I can see that would prevent the
pages being cached.

Updating summary to reflect this.
Summary: Automatic re-load of web-page → Automatic re-load of web-page (when a frame dynamically resized with JavaScript)

Comment 11

17 years ago
Created attachment 75831 [details]
Ignore: Top frame for testcase

This is the top frame for the testcase (which I'm about to attach). It contains
a couple of buttons which will change the size of the frames. It will throw up
a JavaScript alert each time it is loaded.

Comment 12

17 years ago
Created attachment 75832 [details]
Testcase

Frameset which loads the above attachment in the top frame.

Comment 13

17 years ago
The above testcase shows this bug in action. When you click the buttons the
frames are resized, causing both frames to be reloaded (the top frame will alert
each time it is loaded - just so you can be doubly sure).

Note that resizing the frame by dragging the border causes the document to
reflow - this is what the JavaScript should do too, without reloading anything.
Keywords: testcase

Comment 14

16 years ago
The usage on the page first mentioned in this bug is kinda lame. There are valid
uses for this though. I am currently building a web application and need to be
able to allow the user to change the size of a frame by clicking a link. I have
been able to do this with javascript code with one problem, Mozilla reloads each
frame where IE doesn't. (Not sure if Netscape 4.* does or not.. I'm not
supporting it anymore). Sorry for the spam, just wanted to say that there ARE
valid reasons for this to be fixed and that I hope it can be soon.

Comment 15

16 years ago
this bug could/should be a dupl of bug 48422

*** This bug has been marked as a duplicate of 48422 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.