cannot open notification tray while banner is open

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
8 months ago

People

(Reporter: dietrich, Unassigned, Mentored, NeedInfo)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=js])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Flame, nightly channel, Nov 1.

STR:

1. take a screenshot
2. see the banner notifying that the screenshot was taken
3. quickly try to open the notification tray

Expected: Banner goes away, notification tray opens

Actual: Cannot open notification tray until banner is gone
(Reporter)

Updated

4 years ago
Mentor: dietrich
(Reporter)

Comment 1

4 years ago
See also bug 988530.
(Reporter)

Updated

4 years ago
Whiteboard: [lang=js]

Comment 2

4 years ago
I'm working on a solution, in the meantime I noticed that just moving the timeout from 5 seconds to 3 really improves the user experience, 5 looks too much to me

Comment 3

4 years ago
btw I just see that the bug #988530 sort of agree with me, 2 though could be insufficient because of the opening animation.

I think another solution would be detecting a swipe down action, and pushing down the notification tray in that case;
Another solution could be that the tap action would open the notification tray instead of the program associated with it.

I'm working on the swipe down, feel free to stop me and suggest a different approach.
(Reporter)

Updated

4 years ago
Flags: needinfo?(dietrich)

Comment 4

4 years ago
In my branch here: https://github.com/kentaromiura/gaia/tree/notifications-improvements I've made a couple of changes, basically now the toaster timeout is 3 seconds and its pointer-events is none, 
before doing a PR, I'd like to know if 3s it's ok, otherwise I can drop to 2, also since pointer-events is now none, I'd like to know if adding a bit of opacity (either using opacity or rgba) to let the user know that he's touching on the search box, for example, and also there's some code that can be deleted now, since tapping is disabled.

waiting for more info.

Comment 5

4 years ago
I am looking into it as well and I will be offering a different solution than the current implementation based on a notification bubble.

Comment 6

4 years ago
Created attachment 8515693 [details]
Notifications as bubbles

Comment 7

4 years ago
There are some interesting ideas here - I think they basically amount to turning notification toasts into transient, non-interactive messages, rather than solid notifications as they are now.

It's worth noting, that prior to 2.1 (maybe prior to 2.0? Not sure when the notifications re-style got in), notification toasts could be swiped away, so this is now a more major issue than it used to be. It may be worth filing this regression as a separate bug, but I don't know what the UX/visual spec is to know if this was intentional or not.

This was a common complaint in the bug bash we did in London last weekend, and I think is a valid one - n?robmac to get some UX comment on this, especially with regards to comment #4 and comment #6.
Flags: needinfo?(rmacdonald)

Comment 8

4 years ago
You can swipe up from the notification to make it go away.

Comment 9

4 years ago
This is valid on Firefox OS 2.2
(In reply to marco from comment #8)
> You can swipe up from the notification to make it go away.

wow, I had no idea!
(Reporter)

Comment 11

4 years ago
+1 on swipe down to still open notification tray. that makes the banner notify but without interference of user activity.

also +1 on moving to 3 seconds in that other bug (heheh, also filed by me i see!), but that's for that bug.

this bug is specifically about banners blocking notification try pull down action.

we shouldn't creep the scope to cover bubbles or banner lifetime. i like the bubbles though! like cwiis said, there's a lot of ambient thought by different people about revisiting notifications in the OS. (ios and android have already moved to much more mature notification models.)
Flags: needinfo?(dietrich)
(Reporter)

Comment 12

4 years ago
(In reply to Chris Lord [:cwiiis] from comment #10)
> (In reply to marco from comment #8)
> > You can swipe up from the notification to make it go away.
> 
> wow, I had no idea!

me either. perfectly illustrates the problem with undiscoverable UI :/

also, it's another step - more cognitive load for the user to bear.

the "just works" solution is to let the notification bar come down as expected.
(Reporter)

Comment 13

4 years ago
Carlesso, looks like we have the go-ahead in bug 988530 to switch to 2 seconds. Are you interested in making a patch for it? :D
Flags: needinfo?(kentaromiura)
As Dietrich points out we can go ahead and switch to 2 seconds. Further modifications to address the undiscoverable UI or change the notification behvaiour (as Rob comments in the other bug) need further design work and discussion.

Perhaps this bug can shorten the notification display time and a follow up bug could be opened to further address the other comments...? I'll leave that to Dietrich! :)
Flags: needinfo?(rmacdonald)
(Reporter)

Comment 15

4 years ago
(In reply to Tiffanie Shakespeare from comment #14)
> As Dietrich points out we can go ahead and switch to 2 seconds. Further
> modifications to address the undiscoverable UI or change the notification
> behvaiour (as Rob comments in the other bug) need further design work and
> discussion.
> 
> Perhaps this bug can shorten the notification display time and a follow up
> bug could be opened to further address the other comments...? I'll leave
> that to Dietrich! :)

See comment #11.

This bug is the "allow notification bar to be dragged open even while a banner is visible" bug.

Bug 988530 is the "shorten banner lifetime" bug - the title of which is "banner lifetime is too long".

Let's not completely reverse the purpose of both bugs, would be too confusing ;)
Flags: needinfo?(tshakespeare)
whoops! Too many bugs open :) Yes, let's let the other bug solve the 2 second fix and leave this one open to address any UI changes we may want to do in the future. 

Thanks Dietrich!
Flags: needinfo?(tshakespeare)

Updated

4 years ago
Keywords: polish

Comment 17

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.