Downloading file while Mozilla is hidden can cause crash

RESOLVED WONTFIX

Status

Core Graveyard
File Handling
--
major
RESOLVED WONTFIX
16 years ago
2 years ago

People

(Reporter: Jason Slaughter, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I seem to have found a crasher bug that probably only affects Mozilla on 
Mac OS X. I've searched bugzilla extensively and didn't see it, so hopefully 
this isn't a repeat.

To see this crash, do the following in Mac OS X:

1) Start a file download (so that the "Saving File..." window opens).
2) Before the file finishes downloading, hide Mozilla (command-H)
3) Wait for the file to finish downloading.
4) Right-click (or click-hold) the Mozilla icon in the dock.

After doing the above, Mozilla crashes every time for me (0.9.5, Build ID: 
2001101516)
(Reporter)

Comment 1

16 years ago
One more thing: "Keep this window open after download" must be *
unchecked* for this to crash Mozilla. 

This crash is probably due to the "Saving file" being automatically closed 
after the download is complete, but Mozilla/Mac OS X still expecting the 
window to be listed in the dock menu.

Comment 2

16 years ago
Confirming issue in the Nov 9th build.


S Version: 10.1 (Build 5L21)

Command:    Mozilla
PID:        485

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x000000a4

Thread 0:
 #0   0x73211b1c in CreateWindowMenuForDock
 #1   0x7318d80c in DockCallback__FUlPvn2
 #2   0x73d74060 in ClientMessageHandler
 #3   0x701a44b4 in __CFMessagePortPerform
 #4   0x7018f134 in __CFRunLoopDoSource1
 #5   0x7017c104 in __CFRunLoopRun
 #6   0x701b6ba0 in CFRunLoopRunSpecific
 #7   0x7017b804 in CFRunLoopRunInMode
 #8   0x7312d844 in RunEventLoopInModeUntilEventArrives
 #9   0x731c3b94 in RunEventLoopUntilEventArrives
 #10  0x731a173c in GetNextEventMatchingMask
 #11  0x7312384c in EventAvail
 #12  0x01c803c8 in GetEvent__16nsMacMessagePumpFR11EventRecord
 #13  0x01c80244 in DoMessagePump__16nsMacMessagePumpFv
 #14  0x01c7fbb4 in Run__10nsAppShellFv
 #15  0x01a78ccc in Run__17nsAppShellServiceFv
 #16  0x004cc510 in main1__FiPPcP11nsISupports
 #17  0x004cd0b8 in main

Thread 1:
 #0   0x7000530c in syscall
 #1   0x70557590 in BSD_waitevent
 #2   0x70554a30 in CarbonSelectThreadFunc
 #3   0x70020efc in _pthread_body

Thread 2:
 #0   0x7003fe48 in semaphore_wait_signal_trap
 #1   0x7003fc48 in _pthread_cond_wait
 #2   0x705594ac in CarbonOperationThreadFunc
 #3   0x70020efc in _pthread_body

Thread 3:
 #0   0x70043988 in semaphore_timedwait_signal_trap
 #1   0x70043968 in semaphore_timedwait_signal
 #2   0x7003fc38 in _pthread_cond_wait
 #3   0x7028366c in TSWaitOnConditionTimedRelative
 #4   0x7027cf10 in TSWaitOnSemaphoreCommon
 #5   0x702c14c8 in TimerThread
 #6   0x70020efc in _pthread_body

Thread 4:
 #0   0x7003fe48 in semaphore_wait_signal_trap
 #1   0x7003fc48 in _pthread_cond_wait
 #2   0x702505cc in TSWaitOnCondition
 #3   0x7027cef8 in TSWaitOnSemaphoreCommon
 #4   0x7024386c in AsyncFileThread
 #5   0x70020efc in _pthread_body

Thread 5:
 #0   0x7003fe48 in semaphore_wait_signal_trap
 #1   0x7003fc48 in _pthread_cond_wait
 #2   0x7055b9b4 in CarbonInetOperThreadFunc
 #3   0x70020efc in _pthread_body

Thread 6:
 #0   0x70001308 in mach_msg_overwrite_trap
 #1   0x70006394 in mach_msg
 #2   0x700273dc in _pthread_become_available
 #3   0x700270d4 in pthread_exit
 #4   0x70020f00 in _pthread_body


PPC Thread State:
  srr0: 0x73211b1c srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x20000020   lr: 0x73211b1c  ctr: 0x70161ff0   mq: 0x00000000
    r0: 0x73211b1c   r1: 0xbfffea10   r2: 0x03e293ac   r3: 0x00000000
    r4: 0x75b8c82f   r5: 0xbfffe8f8   r6: 0x00000007   r7: 0x00000007
    r8: 0x00000002   r9: 0xffffffff  r10: 0xa1b1c1d3  r11: 0x00000007
   r12: 0x03d53e40  r13: 0x00000000  r14: 0x00000036  r15: 0xbfffee58
   r16: 0xbfffee70  r17: 0x00000001  r18: 0x00075158  r19: 0x00000e07
   r20: 0x00000000  r21: 0x0000001c  r22: 0x70004bc4  r23: 0x70004c58
   r24: 0x706bab4c  r25: 0x000006eb  r26: 0x8081ab5c  r27: 0x00056fc0
   r28: 0x00000000  r29: 0xbfffef00  r30: 0x8081d1cc  r31: 0x00000001

**********

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
->pink
Assignee: asa → pinkerton
Component: Browser-General → File Handling
(Assignee)

Comment 4

16 years ago
i think this is an OS bug since it crashes down in OS code trying to create the
dock menu. it's probably confused because the window has gone away w/out
notifying someone (possibly the window server).

I've posted to apple, we'll see what they say.
Status: NEW → ASSIGNED
(Assignee)

Comment 5

16 years ago
this is a confirmed bug in the OS. searching for workaround, but probably won't
find one.
(Assignee)

Comment 6

16 years ago
apple can't think of a workaround either.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 7

16 years ago
Surely the workaround is to make Mozilla visible?
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.