Closed Bug 1092540 Opened 6 years ago Closed 6 years ago

In default settings Firefox sends local addresses like server/private to a search engine which leaks local network information.

Categories

(Firefox :: Untriaged, defect)

33 Branch
x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1083634

People

(Reporter: zrin+mozilla, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141027150301

Steps to reproduce:

Enter a local address like server/private in the address bar and press Enter.


Actual results:

The address server/private is sent to the currently selected search engine - leaking local network information to the public Internet.
This is different than it used to be in previous versions.


Expected results:

Firefox should respect local addresses and connect to the local server.
Setting which can leak information about local network should not be the default setting.

Temporary workaround: turn off searching from the address bar.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1083634
You need to log in before you can comment on or make changes to this bug.