Lightning stops synchronizing on some (but not all) calendars of Gmail account

RESOLVED WORKSFORME

Status

Calendar
Provider: CalDAV
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: prr0616, Unassigned)

Tracking

Lightning 3.3

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141011015303

Steps to reproduce:

Establish multiple Google Calendars from a single Gmail account
Establish a single calendar from a different Gmail account
All calendars us the CalDAV method of accessing the Google calendars.  Here is a representative example of one of the calendars:  https://apidata.googleusercontent.com/caldav/v2/rqnktv23359b9vvp7q7kkg2j94@group.calendar.google.com/events  



Actual results:

For a few days, everything worked perfectly.  Calendar entries entered in Lightning went to the Google calendar, and vice versa.  Then sometimes (but not every time) the first time I opened Thunderbird after the computer being shut down I would get a popup asking for passwords.  If I put the password in everything was fine.  Finally, the single calendar, and some but not all of the calendars on the account with multiple calendars stopped synching completely, and I never got the popup again.  I was able to open the properties on the non-synching calendars and click the Switch this Calendar On checkbox, but it immediately turn off when I closed the popup.  I then tried to create a new calendar, copying and pasting the calendar ID from the Google Calendar, and I got an error message that I was already subscribed to a calendar at that location.  I then deleted the calendar and was able to create it and have it synch in both directions.  I have now done this at least 5 times for 7 calendars, and it is tedious and annoying. It would be less tedious (though not less annoying) if I could edit the location line for the calendar, but it is not only not editable but uncopyable.

I re-established the single calendar and one of the joint calendars using the identical method of entering the data.  I checked that the calendar ids were identical to the ones 


Expected results:

Once a calendar is subscribed to and working I expect it to keep working.
(Reporter)

Comment 1

4 years ago
Every time one calendar stops working and I have to delete and resubscribe, the calender id's are identical to the ones that stopped working.  Passwords are stored in Thunderbird and have not changed during this entire mess.  I stopped using Provider because I got a message that provider was obsolete and from what I could find on the web (lots of obsolete and conflicting information on how to use Lightning wit Google calendar) CalDAV was the way to go.

It didn't ask me but I'm using 31.2.0 Thunderbird and I checked what version of Lightning I should be using with this version of Tbird, and I believe I'm using the correct one.

Comment 2

4 years ago
Lightnig  3.3.x (currently 3.3.1) is the correct version for TB 31. You can still use the Provider (current version 1.0.2).

Have you any messages in the error log when expiriencing the problem?
Component: Lightning Only → Provider: CalDAV
(Reporter)

Comment 3

4 years ago
I didn't realize there was an error log.  Can you tell me how to get at it?  Also I now remember that the issue I had with Provider, was not that it was obsolete, but that I kept getting over quota messages.  I'm sorry that I don't remember the details, of the error message at this point. I did some web searching and what I read implied that it was because Provider was obsolete and CalDav was the way to synch calendars. I'll go back to Provider for the time being.

Comment 4

4 years ago
Just press ctrl+shift+j to access the error log. CalDAV and the provider are two alternative ways to access the Google calendar using different APIs. Google has quotas on each of them.
(Reporter)

Comment 5

4 years ago
Provider working perfectly now!  Thanks for the update

Comment 6

3 years ago
Resolving WFM based on comment #5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.