Closed Bug 109263 Opened 19 years ago Closed 19 years ago

Number of characters for multibyte character isn't calculated correctly

Categories

(Core :: Internationalization, defect, P3)

x86
Windows 2000
defect

Tracking

()

VERIFIED DUPLICATE of bug 98434
mozilla0.9.9

People

(Reporter: kazhik, Assigned: tetsuroy)

Details

(Keywords: intl)

Number of characters for multibyte character seems to be calculated
as number of bytes.

In input field with "maxlength=10", Mozilla allows 5 Japanese characters.

Testcase:
http://bugzilla.mozilla.gr.jp/showattachment.cgi?attach_id=368

Original report in Bugzilla-jp:
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=1532
accepting for 0.9.8
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla0.9.8
Keywords: intl
Target Milestone: mozilla0.9.8 → mozilla0.9.9
Keywords: nsbeta1
dup of bug 109818?

*** This bug has been marked as a duplicate of 98434 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.