Segfault when saving link as

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
--
critical
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Nicolas Fritsch, Assigned: Darin Fisher)

Tracking

({crash})

Trunk
x86
FreeBSD
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:0.9.5) Gecko/20011106
BuildID:    Mozilla 0.9.5,1 (no build ID, personal build on bsd 4.4)

When saving twice the same link, mozilla segfaults. The link to save is actually
a redirection generated by a servlet to ensure the user is logged in.

Reproducible: Always
Steps to Reproduce:
1. Go to
http://link.springer.de/link/service/journals/10044/bibs/1004004/10040244.htm
2. Do a "Save link as" on "Article in PDF format"
3. Vie a name, save the link
4. Do it again: "Save link as" on "Article in PDF format"
5. Give a name, save
6. Mozilla will give you a popup "There was an error reading from the source
location". If you click on OK (which is the only button :-)), mozilla will segfault.

Actual Results:  Segfault

Expected Results:  No segfault :-) Even if there's a Tech Evangelism pb, mozilla
should display an error messaage, but not crash.

This only seems to occur the second time you save the link, never the first time.

Comment 1

17 years ago
I can't reproduce this on linux using an 0900GMT build. Reporter: do you have to
be logged in to see this problem?
Keywords: crash
(Reporter)

Comment 2

17 years ago
No. I actually have no account to log in...

Comment 3

17 years ago
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.5+) Gecko/20011108
I could save it, but content is short HTML file - Error 401 Not authorized.
No crash.
Reporter: Can you please use a talkback enabled build and poste the talkback ID.
(Reporter)

Comment 5

17 years ago
Sure. I'm going to build a debug version, and send a core dump. If it still core
dumps :-)
(Reporter)

Comment 6

17 years ago
I tried to reproduce the bug with the build on FreeBSD 4.4 install CD
(mozilla-0.9.3,1), but couldn't. No BUILD ID, sorry, still 0 (how are these
generated?). It seems it only happens with my build; could it be generated by
compiler's optimizations? (I use -O2 -march=i686).

I will try to build a debug version, but I need more disk space for that :-)

Comment 7

17 years ago
Whis worksforme with 2001121207, creating a file called 10040244.pdf with the
following contents:

<HTML><HEAD><TITLE>Error</TITLE></HEAD><BODY><H1>Error 401</H1>Not authorized.  
Authentication failed.<P><HR><ADDRESS><A HREF="http://link.springer.de/">Lotus D
omino Go Webserver 4.6.2.2</A></ADDRESS></BODY></HTM

Please reopen if problem seems to reoccur.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.