Textfields created with innerHTML is empty

VERIFIED DUPLICATE of bug 17003

Status

()

VERIFIED DUPLICATE of bug 17003
17 years ago
10 years ago

People

(Reporter: tmapek, Assigned: jst)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This might be related to bug #50418 and #58089.

Textareas created with innerHTML will be empty.

This code will create a text-area filled with text in IE, but will render an
empty textarea in Mozilla:

<div id="par"><!-- comment --></div>

<script language="javascript">
function paintParagraph() {
	buf = '<textarea>the text</textarea>';
	document.getElementById('par').innerHTML = buf;
	}
paintParagraph();
</script>

Comment 1

17 years ago
Dup of bug 17003 by way of bug 94724.

*** This bug has been marked as a duplicate of 17003 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified dup of bug 17003
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.