Closed Bug 1092819 Opened 5 years ago Closed 5 years ago

Disconnected BufferSourceNode's which are looping don't seem to be GC at any time

Categories

(Core :: Web Audio, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 897796

People

(Reporter: sole, Unassigned)

Details

STR

http://sole.github.io/test_cases/web_audio/buffersourcenodesgc/

0) open the Web Audio editor in devtools and make sure it catches the audio context initialisation

Test 1: getting not GC nodes

1) Make sure 'loop' is selected
2) Press 'trigger' a few times so the sample is triggered various times. Disconnected garbage-collectable AudioBufferSource nodes will start to pile in the Web Audio Editor, they never disappear

Reload the page

Test 2: getting nodes GC'ed

1) Make sure 'loop' is not selected
2) Press 'trigger' a few times
3) Wait a bit and the nodes will be garbage collected after a while

It's as if the engine keeps references to them to be able to loop.
I made an screencast showing the bug in action: https://www.youtube.com/watch?v=7HkrqJJEdmw
Discussion re a solution here is in bug 897796.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 897796
You need to log in before you can comment on or make changes to this bug.