SoundCloud player doesn't work properly

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: sawrubh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8515628 [details]
about:support of Nightly

STR:
* Open SoundCloud, try and listen to something. For example try playing https://soundcloud.com/davidguetta/david-guetta-dj-mix-215

What happens:
Doesn't play at all, the icon changes to pause but the music doesn't play. Works alright in Chrome.

Attaching my about:support in case it helps.
When you report a bug in a nightly it would be good to know if this works in a Release or if this is a regression in a nightly Build.
I can test on linux but only via remote access (VNC) and that excludes audio....

Soundcloud is using an audio/mpeg (=mp3) stream.

this is an extracted URL from your example but I do not know if this links stays valid.
https://ec-media.soundcloud.com/S1j3UCwWLe8b.128.mp3?f10880d39085a94a0418a7ef69b03d522cd6dfee9399eeb9a522009866ffb635e503d633110af97890fd730ffb9877c59f6171dbfb51b4acaca77be28c19d9ac156b002f0e&AWSAccessKeyId=AKIAJNIGGLK7XA7YZSNQ&Expires=1414978925&Signature=M7JuMhf8Co%2F6WOPBXnST1VZWym4%3D

To make it simpler you test mp3 and other audio codecs playback on this URL (found using google)
http://hpr.dogphilosophy.net/test/

Firefox is AFAIK using gstreamer on Linux to play h264 and mp3 on linux.
via another google search I have found this:
http://linuxtechie.wordpress.com/2014/08/05/enabling-html5-mp3-playback-in-firefox-30-and-above-3/
Maybe you are also missing the gstreamer package ?
Flags: needinfo?(saurabhanandiit)
(Reporter)

Comment 2

4 years ago
So this doesn't work in the stable build as well. I tested the codecs on that webpage and everything except mp3 and flac seems to be working. I'm pretty sure this is due to gstreamer 1.0 not being there. I'll close this bug then.
Flags: needinfo?(saurabhanandiit)
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

4 years ago
Just curious, why don't we also use a fallback solution which Chrome probably does in order to play the sound properly on Linux. Because with the same setup, Chrome is able to play the song (not sure if it used Flash, which might be missing from the system too).
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Mozilla uses the OS support for h264/mp3 to play such content due to patent issues.
Chrome may come with his own h264/mp3 decoder like ffmpeg because they have the money to buy a license 

Anyway: Please use your preferred search engine if you want to know more about the html5 mp3 issue in Firefox
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.