Adding a variable to the watch pane should show its value as well as its name

RESOLVED FIXED

Status

()

Firefox
Developer Tools: Debugger
RESOLVED FIXED
3 years ago
4 months ago

People

(Reporter: Jim Michaels, Unassigned)

Tracking

(Blocks: 1 bug)

33 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141027150301

Steps to reproduce:

added a variable to watch pane in debugger. it shows the variable name as
>>total



Actual results:

nothing else. that's the problem. it's just acts like a dynamic listbox rather than a watch window.


Expected results:

should show the content and maybe even the available properties and methods of the variable total like the watch pane used to.
(Reporter)

Updated

3 years ago
Summary: add watch variable to watch doesn't show variable content → add variable to watch doesn't show variable content

Updated

3 years ago
Component: Untriaged → Developer Tools: Debugger

Updated

3 years ago
Blocks: 1074592
Summary: add variable to watch doesn't show variable content → Adding a variable to the watch pane should show its value as well as its name

Updated

3 years ago
Duplicate of this bug: 1084285
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1084285
(Reporter)

Comment 3

a year ago
this bug is back. tried in 50.0 to add watch
newSuffixStr==str.substr(i,newSuffixLen)
and it cleared all the watch variables.

Comment 4

a year ago
This still seems to be a problem.
As far as I can tell Watches simply do not work. This makes it substantially less useful than Firebug. 
If there is documentation that explains how this is not a bug, please put a link IN the inspector somewhere people can find it.
This is fixed in the new debugger.  Try it in Firefox 56 or higher.  See here for how it works: https://developer.mozilla.org/en-US/docs/Tools/Debugger/How_to/Set_Watch_Expressions
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.