Thumbnail refresh increases the number of visitors

RESOLVED WONTFIX

Status

()

Firefox
New Tab Page
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: Lesia, Unassigned)

Tracking

33 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141027150301

Steps to reproduce:

I have a wordpress account. It is represented among other icons on a new tab page. The password for my account is stored on my PC, so each time I enter wordpress, I'm automaticall logged in and the system knows I am an administrator. Sometimes when I press the New Tab button, Firefoxs renews the screenshot of my account's homepage.


Actual results:

So when Firefoxs renews the screenshot of my account's homepage, I get increase in the number of visitors.


Expected results:

Of course I shouldn't get that increase since the visitor is in fact me! (the previous version of Firefox didn't have that problem)
It's of course a minor issue but quite annoying... :)

Comment 1

4 years ago
How is it reproducible? I have a Wordpress account.
Flags: needinfo?(crazymaths)
Component: Untriaged → New Tab Page
Summary: There is a small problem with my wordpress account statistics → Thumbnail refresh increases the number of visitors
(Reporter)

Comment 2

4 years ago
(In reply to Loic from comment #1)
> How is it reproducible? I have a Wordpress account.

It goes just like that. When the icon for your account's homepage is among other screenshots on the Ne Tab page, Firefox, as far as I can understand, periodically refreshes this screenshot (in particular, I've noticed it doing that when I turn on my PC and then launch Firefox - i.e. when I launch Firefox the first time after the system starts). When Firefox does that, it is counted as if I had a visitor - but that's not true since that visitor was obviously me. Sometimes also when I visit (as admin) my own page (and I'm logged in) my visitor statistics increases. It all started after the last version of Firefox was installed (the New Tab page by the way is altered a bit (it differs from what was before - at least the design differs)). 
The thing is for sure not very important but a kind of annoying...
Flags: needinfo?(crazymaths)

Comment 3

4 years ago
Which Wordpress URL do you have as thumbnail in the New Tab page?
http://<user>.wordpress.com/
or
https://wordpress.com/my-stats (eg)

Comment 4

4 years ago
I'm asking that because I need to find a simple reproducible way to generate a view on the blog stats by taking a thumbnail (without restarting the computer of course).
For info, thumbnails are cached in the folder:
C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>\thumbnails

Maybe deleting the thumbnail of the Wordpress homepage before starting Firefox is the way to add an extra view to the stats.

But I need to know which URL you have thumbnailed...

Comment 5

4 years ago
Ok, I got the STR:
1) Be sure your Wordpress blog (http://<user>.wordpress.com/) is thumbnailed in the new tab page
2) Close FF
3) Open the thumbnails folder and erase the thumbnail related to the blog
4) Restart FF 
5) Open a new tab page to force a capture of http://<user>.wordpress.com/

Result: the "views" countdown is increased by +1 in https://wordpress.com/my-stats

Comment 6

4 years ago
Anyway I don't see why it's a bug. When Firefox is capturing the blog page to store a thumbnail, Wordpress saves this action as a valid view. Same situation if you open your blog in another version of Firefox.

And it appears this behavior is not new to FF33, I tested with FF32, it's the same thing.
(Reporter)

Comment 7

4 years ago
Yes, thanks, Loic. That's exactly what I was trying to say...
To me this behaviour seems to be new since I didn't experience such a thing before (though my homepage was thumbnailed permanently on the New Tab page and that thumbnail got refreshed from time to time, and that didn/t increase the number of visits) Well, as I've said, the issue is not really important, and in case that's a standard behaviour, it's OK...

Comment 8

4 years ago
Yes, for me it's invalid bug. Your opinion, Gijs?

Comment 9

4 years ago
Not sure. We explicitly avoid taking screenshots of private information according to some heuristics, which could be affecting this case. In order to do that, we'd take screenshots based on results that come from different cookie settings, which explains the bug. I'm not sure in what cases we do and don't do that. Tim, do you know what, if anything, can be done here?
Flags: needinfo?(ttaubert)
We do indeed take screenshots in the background for pages that have no thumbnail for some reason. A reason might be that the page is HTTPS for example, I forgot whether we take screenshots or not by default for HTTPS though.

We send a request without cookies to not screenshot any private stuff, this clearly works as intended. That the number of visitors goes up is side-effect that we really can't care too much about. If it's only you increasing your visitor count every two days then you could simply expect that to happen :)
Flags: needinfo?(ttaubert)
(Reporter)

Comment 11

4 years ago
(In reply to Tim Taubert [:ttaubert] from comment #10)
> That the number of visitors goes up is
> side-effect that we really can't care too much about.

OK, sorry I added you some unnecessary business (i.e. reading these unnecessary posts - no irony or hidden offence involved, I'm indeed sorry).

> If it's only you
> increasing your visitor count every two days then you could simply expect
> that to happen :)

Oh yes, of course, but some of my friends (from my own country - since when it's another country there's no problem obviously) visit my page from time to time and I just can't make out when it's me or them :) (and I'd love to, but I can live with that (I just deleted the thumbnail and try not to let it appear there on the New Tab page again), no big deal, as I've already said).

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(In reply to Lesia from comment #11)
> OK, sorry I added you some unnecessary business (i.e. reading these
> unnecessary posts - no irony or hidden offence involved, I'm indeed sorry).

Really no need to be sorry. Thanks for taking the time to file a bug!

> Oh yes, of course, but some of my friends (from my own country - since when
> it's another country there's no problem obviously) visit my page from time
> to time and I just can't make out when it's me or them :) (and I'd love to,
> but I can live with that (I just deleted the thumbnail and try not to let it
> appear there on the New Tab page again), no big deal, as I've already said).

Thanks for your understanding. Your case is indeed quite special and I think aiming for privacy by default is the right thing to do here even if there are some minor side-effects like the one you reported.
You need to log in before you can comment on or make changes to this bug.