[woodduck][Contacts][Call] 3GPP TS 22.030 6.6.4 An abbreviated dialling code shall be able to be read using the following procedure: N(N)(N)#

RESOLVED DUPLICATE of bug 1061130

Status

defect
RESOLVED DUPLICATE of bug 1061130
5 years ago
4 years ago

People

(Reporter: wudduc, Assigned: wudduc)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 wontfix, b2g-v2.0M wontfix, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Assignee)

Description

5 years ago
ALPS01800568
 DEFECT DESCRIPTION:
 It is not display contacts when input 1# in the dialer
 
  REPRODUCING PROCEDURES:
 PRE:insert a sim card and exist some contacts
 1.Enter dialer,input 1#
 2.it is not display the first record of the phonebook --K.O
Hi Gary,
I wonder is the expected result correct?
Blocks: Woodduck
Flags: needinfo?(gchen)

Updated

5 years ago
OS: Windows XP → Gonk (Firefox OS)
Hardware: x86 → ARM

Comment 2

5 years ago
Partner priority

--
Keven
blocking-b2g: --- → 2.0M?
Hi Josh, I think this is a feature request.
Flags: needinfo?(gchen)
Hi all,
   After more offline discussion, we found gaia has handled this issue via `MmiManager`, it called 
`navigator.mozMobileConnections[cardIndex || 0].sendMMI(message)`[1] correctly but it haven't get success response from gecko.

Hi Sku, Hsin-yi,
   Could you help to take a look in gecko side?
   Thanks.

[1]https://github.com/mozilla-b2g/gaia/blob/v2.0m/apps/communications/dialer/js/mmi.js#L65
Flags: needinfo?(sku)
Flags: needinfo?(htsai)

Comment 5

5 years ago
This feature should be done by partner, not by Mozilla.

3GPP TS 22.030 6.6.4
Reading the abbreviated dialling code
An abbreviated dialling code shall be able to be read using the following procedure:
N(N)(N)#
Alternative additional procedures are also permitted.
Flags: needinfo?(sku)
Flags: needinfo?(htsai)

Comment 6

5 years ago
Please let partner know 2.0m will not have this feature.
Flags: needinfo?(jocheng)
Hi Reporter,
This is new feature request which FFOS does not support now. We will not fix this on 2.0M but will try to improve in the future.
Blocks: 1080481, 1087874
blocking-b2g: 2.0M? → ---
Flags: needinfo?(jocheng) → needinfo?(wudduc)
(Assignee)

Comment 8

5 years ago
Hi Josh,

Got it.

Jason
Flags: needinfo?(wudduc)

Updated

4 years ago
feature-b2g: --- → 2.2?

Updated

4 years ago
Summary: [woodduck][Contacts][Call]It is not display contacts when input 1# in the dialer → [woodduck][Contacts][Call] An abbreviated dialling code shall be able to be read using the following procedure: N(N)(N)#

Updated

4 years ago
Summary: [woodduck][Contacts][Call] An abbreviated dialling code shall be able to be read using the following procedure: N(N)(N)# → [woodduck][Contacts][Call] 3GPP TS 22.030 6.6.4 An abbreviated dialling code shall be able to be read using the following procedure: N(N)(N)#
Triage:
This is GCF certification requirement. 
Shawn,
Could you help to provide test case ID? Thanks!
blocking-b2g: --- → 2.2+
feature-b2g: 2.2? → ---
Flags: needinfo?(sku)

Comment 10

4 years ago
Below is the 3GPP spec. to define the test of ADN.

3GPP TS 51.010-1
27.15 Abbreviated Dialling Numbers (ADN)

27.15.4.2 Procedure
a) Retrieve data from SIM entry number 7 using the procedure N(N)(N)#.
b) Retrieve data from SIM entry number 6 using the procedure N(N)(N)#.
c) Retrieve data from SIM entry number 101 using the procedure N(N)(N)#.
d) Retrieve data from SIM entry number 1 using the procedure N(N)(N)#.

27.15.5
Test requirements
1) After step a), the number "+123456789012345" shall be displayed.
2) After step b), the number "00112233" shall be displayed.
3) After step c), the number "**21*44556677#" (or an equivalent representation) shall be displayed.
4) After step d), the number “123” shall be displayed.
Flags: needinfo?(sku)
Hi Shawn -

Is this one duplicate with Bug#1061130 ? If so, partner already fix this one at their end in Gaia side, maybe we can ask partner to sync internally first to get the patch?

Thanks

Vance
Flags: needinfo?(sku)

Comment 12

4 years ago
Yes, the same one as Bug 1061130.
Flags: needinfo?(sku)
Hi Wesly -

Per Comment#12, could you help to communicate with partner woodduck team and ask them to sync with their Xian team to get the patch of this issue?

Thanks

Vance
Flags: needinfo?(wehuang)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1061130

Updated

4 years ago
Flags: needinfo?(wehuang)

Updated

4 years ago
No longer blocks: FxOS-v2.2-features

Updated

4 years ago
Blocks: 1179745

Updated

4 years ago
No longer blocks: 1179745
You need to log in before you can comment on or make changes to this bug.