Closed Bug 1093002 Opened 8 years ago Closed 8 years ago

[Flame][v2.1][Contact]The title name of contact list changes after you lock and unlock the screen.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 verified)

VERIFIED FIXED
2.1 S9 (21Nov)
Tracking Status
b2g-v2.1 --- verified

People

(Reporter: jihao, Assigned: arcturus)

References

Details

(Whiteboard: [p=1])

Attachments

(4 files)

Attached video select_contact.MP4
[1.Description]:
It returns to contact list, but "Select contact" displays as title.
Attachment: logcat_flame_1242.txt and select_contact.MP4
Occurrence time: 00:42

[2.Testing Steps]: 
1. Open contacts app 
2. Press settings button 
3. Press export contacts button 
4. Select "To Media Card" option 
5. Tap the power button to Lock the phone and then tap it again to wake the phone up.
6. Press Close button 

[3.Expected Result]: 
The title display is Contact.

[4.Actual Result]: 
The user return to contact list and the title display is Select contact.

[5.Reproduction build]: 
Gaia-Rev        36d9f52883b420f90b759303609b2d27d6f94f2c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/97fd482ec87a
Build-ID        20141102161201
Version         34.0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
Attached file logcat_flame_0042.txt
Summary: [MGSEI][Flame][v2.1][Contact]The title name of contact list changes after you lock and unlock the screen. → [Flame][v2.1][Contact]The title name of contact list changes after you lock and unlock the screen.
Nice catch, let's try to take a quick look in next sprint.
Target Milestone: --- → 2.1 S9 (21Nov)
Assignee: nobody → francisco
Whiteboard: [p=1]
Status: NEW → ASSIGNED
Attached file Pointer to PR 26113
This PR ends up removing a lot of code. Before we had the proper edit mode with the header antimating and so on, we were changing the normal header, but that's not needed anymore.

We had this problem probably since 2.0
Attachment #8522214 - Flags: review?(jmcf)
Comment on attachment 8522214 [details] [review]
Pointer to PR 26113

Francisco,

the proposed patch introduces at least one regression. When you go to the pick contact activity the title of the app is 'Contacts' instead of 'Select Contact'. 

thanks!
Attachment #8522214 - Flags: review?(jmcf) → review-
(In reply to Jose Manuel Cantera from comment #4)
> Comment on attachment 8522214 [details] [review]
> Pointer to PR 26113
> 
> Francisco,
> 
> the proposed patch introduces at least one regression. When you go to the
> pick contact activity the title of the app is 'Contacts' instead of 'Select
> Contact'. 
> 
> thanks!

If I'm not wrong we had that behavior already in 2.0 (just showing 'Contacts' in a pick activity), that's why I decided to remove the code for changing the header title.

ni Carrie, do you still want the title changed 'Select contact' in a pick activity or are you ok just with 'Contacts'?
Flags: needinfo?(cawang)
Hi, 

For the Contact picker, I'd like to display the header with "Select Contact" and keep the Contact APP header with the title "Contacts". Thanks!
Flags: needinfo?(cawang)
Comment on attachment 8522214 [details] [review]
Pointer to PR 26113

Jose, second round?
Attachment #8522214 - Flags: review- → review?(jmcf)
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #7)
> Comment on attachment 8522214 [details] [review]
> Pointer to PR 26113
> 
> Jose, second round?

The patch works properly, but I have realised that we need also to have the same title 'Select Contact' when we pick an ICE Contact.
Hei Jose, just added to the PR the chance for selecting ice contacts.
Flags: needinfo?(jmcf)
Target Milestone: 2.1 S9 (21Nov) → 2.2 S1 (5dec)
Comment on attachment 8522214 [details] [review]
Pointer to PR 26113

works perfectly

thanks, Francisco
Flags: needinfo?(jmcf)
Attachment #8522214 - Flags: review?(jmcf) → review+
Landed in master:

https://github.com/mozilla-b2g/gaia/commit/072b91a55ce625c8c7681777e0ecd4a4f536bb0e
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: 2.2 S1 (5dec) → 2.1 S9 (21Nov)
QA Whiteboard: [COM=Gaia::Contacts]
Keywords: verifyme
The problem is verified not happen on latest Flame 2.1build.

Steps:
1) Open contacts app 
2) Press settings button 
3) Press export contacts button 
4) Select "To Media Card" option 
5) Tap the power button to Lock the phone and then tap it again to wake the phone up.
6) Press Close button 

  
Actual:
The title display is Contact.
Fail rate:0/5
See attachment:contacts.mp4

Flame 2.1 version:
Gaia-Rev        d98bbe9d2bfdb53e80dc1ab1572bd05938a85526
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/c694578ff69e
Build-ID        20150128001258
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150128.034753
FW-Date         Wed Jan 28 03:48:03 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.