SVG circle disappears at certain radius when drawing in a transformed group

RESOLVED DUPLICATE of bug 1131264

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 1131264
4 years ago
3 years ago

People

(Reporter: JWN, Unassigned)

Tracking

33 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

376 bytes, image/svg+xml
Details
(Reporter)

Description

4 years ago
Created attachment 8515938 [details]
scale_error.svg

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141011015303

Steps to reproduce:

Create the following SVG file (also attached) and open it in Firefox:

<svg width="678" height="400" viewBox="0 0 678 400" xmlns="http://www.w3.org/2000/svg">
    <g transform="scale(0.022614665510518675 -0.02261466551051867),translate(-484912.03893805307 -6229474.298269246)">
        <circle cx="489358" cy="6219804" r="797" stroke="green" fill="green"/>
        <circle cx="488049" cy="6219779" r="796" stroke="red" fill="red"/>
    </g>
</svg>

The file shows two circles, given in UTM map coordinates and transformed to screen coordinates.


Actual results:

The green circle shows; the red does not.


Expected results:

Both circles should be shown. If the radius of the red is increased to 797, it shows.

This is possibly related to 847153.

Comment 1

3 years ago
This is fixed by the patch in bug 1131264.
Status: UNCONFIRMED → NEW
Depends on: 1131264
Ever confirmed: true

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1131264
You need to log in before you can comment on or make changes to this bug.