crash in NPE: Attempt to invoke virtual method ''void org.mozilla.gecko.db.LocalBrowserDB.removeThumbnails(android.content.ContentResolver)'' on a null object reference at org.mozilla.gecko.db.BrowserDB.removeThumbnails(BrowserDB.java)

RESOLVED FIXED in Firefox 38

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: rnewman)

Tracking

({crash})

36 Branch
Firefox 38
All
Android
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox36 affected)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-90523c46-50fd-4657-9592-90d122141102.
=============================================================

java.lang.NullPointerException: Attempt to invoke virtual method 'void org.mozilla.gecko.db.LocalBrowserDB.removeThumbnails(android.content.ContentResolver)' on a null object reference
	at org.mozilla.gecko.db.BrowserDB.removeThumbnails(BrowserDB.java:229)
	at org.mozilla.gecko.MemoryMonitor$StorageReducer.run(MemoryMonitor.java:237)
	at android.os.Handler.handleCallback(Handler.java:733)
	at android.os.Handler.dispatchMessage(Handler.java:95)
	at android.os.Looper.loop(Looper.java:136)
	at org.mozilla.gecko.util.GeckoBackgroundThread.run(GeckoBackgroundThread.java:43)
(Assignee)

Comment 1

3 years ago
This is the same as Bug 1077858. We're calling a static method on BrowserDB when it hasn't been initialized.

The interesting part about this bug is that Gecko is running (we check earlier in the method), so this implies some really unlikely timing -- that we managed to run StorageReducer before GeckoApp.initialize ran.

Again, that implies a window focus issue. But this happened on a 10-31 build, which should be after we turned the first-run experience into a dialogfragment.

This will either be fixed by Bug 1085591 (if the issue is focus-related) or Bug 1077590.
Depends on: 1085591, 1077590
(Assignee)

Comment 2

3 years ago
This should now be impossible after Bug 1077590.
Assignee: nobody → rnewman
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 38
You need to log in before you can comment on or make changes to this bug.