Closed Bug 1093173 Opened 8 years ago Closed 8 years ago

Busy spinners are high-load (power and network) - should be battery/bandwidth aware.

Categories

(Firefox :: Tabbed Browser, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 976058

People

(Reporter: mhoye, Unassigned)

Details

Researcher Abram Hindle reports: 

"We found that blocking on a slow connection used consistently more power than idle. This could be solely due to network traffic, but network traffic was very periodic (1 packet in and 1 packet out per second), thus much of the work could likely be attributed to the animated spinner. The difference was not very large, but it was statistically significant." 

As well, Neil Parkway reports that Firefox over Remote Desktop is very nearly unusable because of the spinner's update frequency.

Spinners should be made power/bandwidth aware, and constrain their refresh rates appropriately.


Related: now-closed Bug 1020858 that fixes the PDF-doesn't-load problem, but doesn't speak to the observation that the pdf.js spinner is pegging a core.
Flags: needinfo?(rvitillo)
Looks like a duplicate of Bug 976058.
Flags: needinfo?(rvitillo)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.