getting "PARSER: CR/LF fell on chunk boundary." when reading a IMAP message

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
17 years ago
6 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

({testcase-wanted})

Trunk
x86
Windows 2000
testcase-wanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When trying to read a mail mozilla just failed silently. no error no nothing. 
But the IMAP log showed the hole thing....:

PARSER: CR/LF fell on chunk boundary.
imap.mail.dk:S-INBOX/Error - Session:STREAM:CLOSE: Normal Message End Download 
Stream
imap.mail.dk:S-INBOX/Error - Session:PARSER:Internal Syntax Error: %s: )
(Reporter)

Comment 1

17 years ago
Just got this again on another mail and on another IMAP 
server. "PARSER:Internal Syntax Error: %s: 30 OK FETCH fuldført."

First one was a software.com and the second a Exchange
(Reporter)

Updated

17 years ago
Blocks: 109327

Comment 2

17 years ago
Do you have a particular message and server you can reproduce this on or does it
appear to be random?  
Status: NEW → ASSIGNED

Comment 3

17 years ago
It's most likely a particular message, but it could be a bit random if the chunk
size is adjusted based on connection speed.
(Reporter)

Comment 4

17 years ago
one problem is that if the server responds is:
3 FETCH (UID 3 RFC822.SIZE 2321 BODY[] NIL)
mozilla still thinks it's gonna get some body data while it's not (due to the
NIL) and then you get:
"PARSER:Internal Syntax Error: %s: 30 OK FETCH fuldført."
Blocks: 126987
No longer blocks: 109327

Updated

16 years ago
QA Contact: huang → gchan
Product: MailNews → Core
Assignee: mscott → nobody
Status: ASSIGNED → NEW
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Updated

10 years ago
QA Contact: grylchan → networking.imap
anyone still see this?
Flags: needinfo?
Keywords: testcase-wanted
Whiteboard: [closeme 2012-12-01]

Comment 6

6 years ago
Resolved per whiteboard
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-12-01]
You need to log in before you can comment on or make changes to this bug.