[Homescreen] Locking screen while in Edit Mode deselects icons when entering unlocking device.

RESOLVED INVALID

Status

Firefox OS
Gaia::Homescreen
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Johnt, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8516107 [details]
logcat_20141103_1026.txt

Description:
From the Homescreen if the User enters  "Edit Mode" and locks the screen followed by returning to the Homescreen the Edit Mode will then be disabled. 

Repro Steps:
1) Update a Flame device to BuildID: 20141103001220
2) Press and Hold one of the Icons to enter Edit Mode.
3) Lock device by pressing the Power button.
4) Observe that the device is no longer in Edit Mode.

Actual:
Device is no longer in Edit Mode.

Expected:
It is expected that the device will remain in Edit Mode.

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141103001220
Gaia: 027a7de0c95320cea0579bfd1a4ceef3e9038f34
Gecko: ffecb2be228b
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 100%
See attached: Logcat
Video: https://www.youtube.com/watch?v=o1tYeczqUC8&edit=vd
(Reporter)

Comment 1

3 years ago
This issue DOES occur on the Flame 2.2 KK (319mb) and the  Flame 2.0 KK (319mb)

Result: Icons that were previously in Edit Mode will no longer be in Edit Mode if the device's screen is powered off and then powered on.

Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141103040202
Gaia: bc168c17474dabbcceaa349e9bc7c95654435aec
Gecko: 5999e92e89ff
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141103000201
Gaia: 7b8df9941700c1f6d6d51ff464f0c8ae32008cd2
Gecko: 82a6ed695964
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
This is the same way it works on iOS so i'm fairly certain that this is by design.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.