Some pages hangs when "favicons" enabled

VERIFIED FIXED in mozilla0.9.7

Status

SeaMonkey
UI Design
--
critical
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Daniel Mario Vega (Restore MNG Support --> #18574), Assigned: David Hyatt)

Tracking

({hang})

Trunk
mozilla0.9.7
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(URL)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.5+) Gecko/20011108
BuildID:    2001110803

If I enable Site Icons (favicons) in my preference file, some web sites hangs
Mozilla

Reproducible: Always
Steps to Reproduce:
1. Enable "favicons" on your preference file "prefs.js". You have to do it
editing the file by hand. There is no UI for that. 
- user_pref("browser.chrome.favicons", true);
2. Open Mozilla
3. Go to http://www.mailandnews.com/


Actual Results:  Mozilla hangs

Expected Results:  Mozilla should display the page
Keywords: hang

Comment 1

16 years ago
Same 20011109/WinNT4
Adding hyatt@netscape.com to cc

Comment 2

16 years ago
Confirming on Win2K 2001110903 build.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: sairuh → claudius
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.7
It also happens on Linux. BuildID 2001110815
Changing OS to All
OS: Windows NT → All

Comment 4

16 years ago
Stack trace: 11/08 2am trunk build

nsICODecoder::ProcessData(nsICODecoder * const 0x000000b5, const char * 
0x02b7bffd, unsigned int 0x00000000) line 229
nsICODecoder::WriteFrom(nsICODecoder * const 0x02ba0b10, nsIInputStream * 
0x029aa2bc, unsigned int 0x000000b5, unsigned int * 0x0012fca0) line 202
imgRequest::OnDataAvailable(imgRequest * const 0x02aed630, nsIRequest * 
0x02aed630, nsISupports * 0x00000000, nsIInputStream * 0x029aa2bc, unsigned int 
0x00000000, unsigned int 0x000000b5) line 722
ProxyListener::OnDataAvailable(ProxyListener * const 0x02c2e568, nsIRequest * 
0x02aed630, nsISupports * 0x00000000, nsIInputStream * 0x029aa2bc, unsigned int 
0x00000000, unsigned int 0x000000b5) line 501
nsHttpChannel::OnDataAvailable(nsHttpChannel * const 0x02aed634, nsIRequest * 
0x02bdf5f4, nsISupports * 0x00000000, nsIInputStream * 0x029aa2bc, unsigned int 
0x00000000, unsigned int 0x000000b5) line 2356 + 23 bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x000000b5) 
line 193 + 24 bytes
PL_HandleEvent(PLEvent * 0x02bb9e8c) line 591
PL_ProcessPendingEvents(PLEventQueue * 0x10033824) line 520 + 6 bytes
_md_EventReceiverProc(HWND__ * 0x01305958, unsigned int 0x004016d1, unsigned 
int 0x00b6c2c0, long 0x00000000) line 1071 + 10 bytes
nsAppShellService::Run(nsAppShellService * const 0x00b6c2c0) line 303
main1(int 0x00000001, char * * 0x00322ba8, nsISupports * 0x00323c40) line 1304 
+ 9 bytes
main(int 0x00000001, char * * 0x00322ba8) line 1630 + 26 bytes
WinMain(HINSTANCE__ * 0x00400000, HINSTANCE__ * 0x00400000, char * 0x00133488, 
HINSTANCE__ * 0x00400000) line 1648 + 21 bytes
MOZILLA! WinMainCRTStartup + 308 bytes
KERNEL32! 77e87

and it's caught in an infinite loop here:
http://lxr.mozilla.org/seamonkey/source/modules/libpr0n/decoders/bmp/nsICODecod
er.cpp#223

The problem is that http://www.mailandnews.com/favicon.ico (or any 404
URL for that server) returns the following response (between the '--'), 
with no headers at all (which is bogus, but we have to deal; it appears
that the GIF decoder defends against bad data, but the icon decoder does
not).

bytes received in response:
--
HTTP/1.0 404 File Not Found!
 
<HTML><BODY><H1>404 File Not Found!</H1>
The requested URI could not be located:  favicon.ico
<p>
Click <a href="/">here</a> for an index of resources on this server.
</BODY></HTML>
--

hyatt: you marked the milestone and assigned; did you mean to take this bug 
from blake at the same time?
Status: ASSIGNED → NEW

Comment 5

16 years ago
yeesh. you be the under-the-desk bitch for a couple days and hyatt starts
thinking he can triage your bugs.  --> favicon whore
Assignee: blakeross → hyatt
This bug seems to be fixed. I think the patch for bug 109870 fixed also this bug.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.