Closed Bug 1093245 Opened 5 years ago Closed 5 years ago

nsHTMLEditorStyle.cpp and nsHTMLEditRules.cpp potentially uninitialized variables

Categories

(Core :: DOM: Editor, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36

People

(Reporter: milan, Assigned: milan)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch Initialize the return values (obsolete) — Splinter Review
I imagine the component is wrong.

nsHTMLEditor::GetInlinePropertyBase doesn't always initialize result, and nsHTMLEditRules::AlignBlockContents doesn't always initialize res, both of which are returned from those functions.
Attachment #8516144 - Attachment is patch: true
Component: HTML: Parser → Editor
Attachment #8516144 - Attachment is obsolete: true
Attachment #8516825 - Flags: review?(ehsan.akhgari)
Comment on attachment 8516825 [details] [diff] [review]
Initialize the return values

Review of attachment 8516825 [details] [diff] [review]:
-----------------------------------------------------------------

Out of curiosity, ow did you find these?  :-)

(And BTW the component is correct.  Thanks for the fix!)
Attachment #8516825 - Flags: review?(ehsan.akhgari) → review+
Aha, just saw bug 1092923.  :-)
Duplicate of this bug: 1092923
(In reply to :Ehsan Akhgari (not reading bugmail, needinfo? me!) from comment #2)
> ...
> 
> Out of curiosity, how did you find these?  :-)
> 
> (And BTW the component is correct.  Thanks for the fix!)

Believe it or not, caught my eye while the build was scrolling in the shell window :)
Assignee: nobody → milan
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/22728e4360f0
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.