After doing "Forget: Last 5 minutes", browser console contains "IndexedDB UnknownErr: IDBDatabase.cpp:776"

RESOLVED DUPLICATE of bug 1083285

Status

()

Core
DOM: IndexedDB
RESOLVED DUPLICATE of bug 1083285
3 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
STR:
 1. Start Firefox with a fresh profile, in an empty folder, like so:
      mkdir /tmp/foo; firefox -profile /tmp/foo -no-remote

 2. Open browser console with Ctrl+Shift+J

 3. Perform a "Forget: Last 5 minutes" action
    (Click hamburger menu, click "customize", drag "Forget" button somewhere, and click it, and click "Forget!")

 4. Look at your Browser Console.

ACTUAL RESULTS: Browser console contains this cryptic error:
IndexedDB UnknownErr: IDBDatabase.cpp:776
(Reporter)

Comment 1

3 years ago
(NOTE: This does not happen with 'clear recent history' (ctrl+shift+del) -- only with 'forget last 5 minutes'. So, it's presumably coming from one of the extra actions that happens with "forget" but not with "clear recent history".)
(Reporter)

Comment 2

3 years ago
Nightly 36.0a1 (2014-11-03)
Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
(Reporter)

Comment 3

3 years ago
Looks like the browser console error refers to this "IDB_REPORT_INTERNAL_ERR" invocation (based on its reported line number, 776):

> 753 void
> 754 IDBDatabase::AbortTransactions()
> 755 {
> 756   AssertIsOnOwningThread();
> 757 
> 758   class MOZ_STACK_CLASS Helper MOZ_FINAL
> 759   {
> 760   public:
> 761     static void
> 762     AbortTransactions(nsTHashtable<nsPtrHashKey<IDBTransaction>>& aTable)
> 763     {
[...]
> 776       IDB_REPORT_INTERNAL_ERR();
http://mxr.mozilla.org/mozilla-central/source/dom/indexedDB/IDBDatabase.cpp?rev=45dad11b6580&mark=776-776#753
(Reporter)

Comment 4

3 years ago
Created attachment 8516168 [details]
backtrace

Here's the backtrace of when I hit this line.

Looks like it's associated with window-closing (at least, there are mentions of "inner-window-destroyed" in the backtrace), and that causes us to abort some transactions.

If this is an expected thing, we shouldn't be reporting it as an error.  (Or, if there's some reason we need to report it, surely we should be providing more details than just "IndexedDB UnknownErr: IDBDatabase.cpp:776")
(Reporter)

Comment 5

3 years ago
This line was added here:
 http://hg.mozilla.org/mozilla-central/diff/8892214038df/dom/indexedDB/IDBDatabase.cpp#l1.1287

...in bug 994190.


Looking at that bug's dependencies, I found bug 1083285; looks like this is a dupe of that.
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1083285
You need to log in before you can comment on or make changes to this bug.