[Downloads] Tapping the 'download started' notification, the 'edit downloads' header will flash

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System::Window Mgmt
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: Petes, Assigned: albertopq)

Tracking

({regression})

unspecified
2.1 S8 (7Nov)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.1-exploratory-3] [systemsfe], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8516285 [details]
ed.txt

Description:
When user tap on the 'download started' notification, the 'edit downloads' header/text will flash

Setup Steps:
1) Flame device is set to 319mb

Repro Steps:
1) Update a Flame device to BuildID: 20141103001220
2) Download a file from  https://owd.tid.es/dm/ 
3) Tap on the 'download started' notification


Actual:
the 'edit downloads' header/text appears

Expected:
the 'edit downloads' header/text does not display


Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031061804
Gaia: a07994714f0552f89801d6097982308d8b0a1ee1
Gecko: 6bd2071b373f
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0


Repro frequency: 100%
See attached: video, logcat, https://www.youtube.com/watch?v=UaLnMsucazw
(Reporter)

Comment 1

4 years ago
This issue does not reproduce on the Flame 2.1 and the Flame 2.0, the 'edit downloads' header/text does not display.

Flame 2.1 

Device: Flame 2.1 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031001201
Gaia: f89c7b12c36572262c9ea76058694a139b1a8634
Gecko: 50d48f8a04c7
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141031000201
Gaia: 7b8df9941700c1f6d6d51ff464f0c8ae32008cd2
Gecko: 82a6ed695964
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Whiteboard: [2.1-exploratory-3] → [2.1-exploratory-3] [systemsfe]
NI to settings owner for a blocking call:  This is a regression but is only a quick flash of a message and might not be worth blocking release for (please refer to video).
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell) → needinfo?(gchang)
[Blocking Requested - why for this release]:

This might need System FE team's help to triage this.
blocking-b2g: --- → 2.1?
Flags: needinfo?(gchang)
Not bad enough to block on it that late in the game.
blocking-b2g: 2.1? → backlog
(Assignee)

Updated

4 years ago
Assignee: nobody → apastor
(Assignee)

Comment 5

4 years ago
I would say this is in the Settings app plate (as we are opening an activity when clicking on the notification). Should we reassign?

Thanks!
Flags: needinfo?(mhenretty)
Transitions with activities are still on systemsfe to figure out. If the settings app is doing something weird after the activity starts that causes the flashing, then it is on their plate. But until we can confirm that, we should investigate.
Flags: needinfo?(mhenretty)
(Assignee)

Comment 7

4 years ago
The header that is flashing is in the settings app itself. I think they are showing it by default, and hiding via JS. That works when navigating through the app, but doesn't hide it fast enough for an activity. Just tried hiding the edit header by default [1] and it works fine.

https://github.com/albertopq/gaia/commit/c960247a20f00b10c00d2ff1d2d3b53b3d69e4ec

Arthur?

Thanks!
Flags: needinfo?(arthur.chen)
I believe the reason is that when opening the panel via activity the setting app needs time for loading some basic modules, so the execution time of the code that hides the header is delayed.

Hiding the header by default makes sense and I'm fine with it. A more proper solution would be using separate html files for the two panels.
Flags: needinfo?(arthur.chen)
(Assignee)

Comment 9

4 years ago
Created attachment 8518086 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/25876

I'm not too familiar with the Settings code, but I don't think this can cause any side effect. Sending r?
Attachment #8518086 - Flags: review?(arthur.chen)
Comment on attachment 8518086 [details] [review]
Link to Pull Request: https://github.com/mozilla-b2g/gaia/pull/25876

Looks good to me! r=me.
Attachment #8518086 - Flags: review?(arthur.chen) → review+
(Assignee)

Comment 11

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/4a2c7249c378d8f697b30a5f7959b7b0aa7687f1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S8 (7Nov)
This issue is verified fixed on Flame 2.2.

Result: "Edit downloads" header does not appear.

Device: Flame 2.2 (319mb, KK, Shallow Flash)
BuildID: 20141119040205
Gaia: e64428c5b2dce5db90b75a5055077a04f4bd4819
Gecko: bc2c36dda0a9
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: affected → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.