If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

novell.com - fonts aren't inherited

RESOLVED WORKSFORME

Status

()

Core
DOM: CSS Object Model
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Tony Tovar, Assigned: Marc Attinasi)

Tracking

Trunk
mozilla1.1alpha
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
(I am using the 2001-11-06(03) Nightly build)

Novell recently updated their web-site so I don't know if this problem is due 
to that or to Mozilla.  If you go anywhere on their site, then do a search, the 
search result page is misformatted and almost unusable.

Comment 1

16 years ago
WFM on 2001101914 (~N6.2) / NT 5.1

Perhaps attach a screenshot of what you're seeing?
(Press ALT-PrintScreen on corrupted results page, paste into Paint)

Or a link to the search results page?
(Reporter)

Comment 2

16 years ago
Created attachment 57288 [details]
Screen-capture showing the search dialog (before)
(Reporter)

Comment 3

16 years ago
Created attachment 57290 [details]
screen-capture of corrupted search result (after)
(Reporter)

Comment 4

16 years ago
Created attachment 57291 [details]
HTML code of "corrupt" search result (after)
(Reporter)

Comment 5

16 years ago
Well, I've uploaded three attachments but they seem to have added to the 
mystery rather than answered it.

In particular, the HTML code I captured from the "corrupt" result window does 
not appear to be corrupt at all.  If I manually load it into Mozilla (or IE), 
it displays fine.  The only problem is when it is first displayed by Mozilla 
(as shown in the "after" screen-capture).

So, this seems to confirm that the problem is in Mozilla, rather than in 
Novell's HTML.
-> Layout
Assignee: asa → attinasi
Component: Browser-General → Layout
QA Contact: doronr → petersen

Comment 7

16 years ago
Confirming this bug on Win 98, build 2001112104. 

I had to go to the "knowledgebase text search" and then enter my search. The
results were the same as indicated in the screenshot. This looks like a Mozilla bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

16 years ago
Same problem on developer.novell.com.
I think the real problem is with CSS not being included and the DIV boxex with
menus etc. are not positioned where they should be. CSS stylesheet
(http://www.novell.com/inc/novellstyle2001.css)
 on these pages is included from JavaScript
(http://www.novell.com/inc/hdr_script.js). I don't have enough JS
experience to tell why the stylesheet is not processed. I walidated the CSS on
www.w3.org and it looks good, so the problem is probably in JS.

Petr Kures

Updated

16 years ago
Target Milestone: --- → mozilla1.1

Comment 9

16 years ago
I can't even get to the point where I can search the web site anymore. Do we
have to register now to search? 
(Reporter)

Comment 10

16 years ago
Created attachment 68214 [details]
Correct search result (with unchanged fonts)
(Reporter)

Comment 11

16 years ago
Created attachment 68215 [details]
Less-corrupted search-result (but w/o original fonts)
(Reporter)

Comment 12

16 years ago
No, there's no need to login.

Go to the following URL,
  http://support.novell.com/filefinder/month/indexc.html
At the far-right of the top-banner, you'll see the "Search->" link.
-------------------

UPDATE
It works better now!  (I'm using 2002012903.)  A search for keyword "java" in 
Novell Support now returns a readable page of HTML.  It's still 'losing' the 
original fonts, though.  

I uploaded 2 screen captures: the "correct" search result (with unchanged 
fonts); the "improved" search result with this version of Mozilla.

Comment 13

16 years ago
Awesome. It must have been fixed by a patch. At this point, we could resolve the
bug worksforme. Alternatively, if you want to change the bug to focus on the
font issue, we can do that, too. There are some big font problems in Mozilla, as
you know.
(Reporter)

Comment 14

16 years ago
I'd rather keep this bug open.  Either rename it (I don't know if I have
access-rights to do it), or mark it as blocked by one of the CSS/Font bugs.

Comment 15

16 years ago
Old Summary: novell.com - search results are corrupted

New Summary: novell.com - fonts aren't inherited

Changing component to DOM Style. Not sure this is the right component. Sorry if
it's wrong.

Does this, in the HTML code of the page, have anything to do with the problem?

<style TYPE="text/css">
.ffDate { color: #CC0000 }
.ffSize { color: #FF9933 }
.ffInput { font-size: 10px }
</STYLE>

Component: Layout → DOM Style

Comment 16

16 years ago
Really changing summary.
Summary: novell.com - search results are corrupted → novell.com - fonts aren't inherited
(Reporter)

Comment 17

16 years ago
Andrew,
Were you asking ME about the <STYLE> command?  I dunno!

P.S.  This is still an issue with Mozilla 0.9.9.

Updated

16 years ago
Keywords: qawanted
(Reporter)

Comment 18

16 years ago
As on Mozilla 2002-03-19(03) on WinNT, this is working correctly.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Re-resolving as WFM, as no specific patch was applied (to this bug)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
And, -> WFM
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.