[Email] Linking a new email and then force quitting on the New Account page causes the login screen to show for a few seconds next time the app is opened

RESOLVED WONTFIX

Status

Firefox OS
Gaia::E-Mail
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: RobertM, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8516402 [details]
Flame2.1logcat.txt

Description:
Setting up a new email account and following the flow until you get to the final window, the New Account page, and force quitting out causes the next time you open the email app to stay on the new account setup page for a few seconds before jumping to your newly created account.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141103001220
2) Tap the 'Email' app
3) Add an existing email and follow the steps until you get to New Account page
4) Hold home button and force quit
5) Reopen the 'Email' app and observe
  
Actual:
Sits on New Account page for a few seconds then connects to added account
  
Expected: 
Goes straight to new account page or back to the final steps of the account setup
  

Flame 2.1(319mb)(KitKat)(Full Flash)

Environmental Variables:
Device: Flame 2.1
BuildID: 20141103001220
Gaia: 027a7de0c95320cea0579bfd1a4ceef3e9038f34
Gecko: ffecb2be228b
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 34.0 (2.1)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Notes: If you force quit again while it is loading, you can keep getting this issue again.
  
Repro frequency: 100%
See attached: logcat, video - http://youtu.be/kB2tKLE-p_w
(Reporter)

Comment 1

4 years ago
This issue also occurs on Flame 2.0(319mb) and Flame 2.2(319mb)

Linking an email and then quitting on the final step, only to reopen the email app causes it to remain on New Account Setup page for a few seconds before continuing to the new account.


Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141103000201
Gaia: 7b8df9941700c1f6d6d51ff464f0c8ae32008cd2
Gecko: 82a6ed695964
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 32.0 (2.0) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Flame 2.2

Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141103040202
Gaia: bc168c17474dabbcceaa349e9bc7c95654435aec
Gecko: 5999e92e89ff
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
This is an artifact of the HTML cookie cache for accelerating startup in the normal case.  This is the expected outcome for these set of steps.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Duplicate of this bug: 1094711
You need to log in before you can comment on or make changes to this bug.