passcode entry on lockscreen no longer has delete key (just Cancel) after entering one character

VERIFIED FIXED in 2.1 S9 (21Nov)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: dbaron, Assigned: gweng)

Tracking

({regression})

unspecified
2.1 S9 (21Nov)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 fixed)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
timdream
: review+
Details | Review
This is a regression from a few weeks ago; I hadn't gotten around to filing.  I don't remember exactly when it regressed.

I'm using self-built userdebug builds of B2G master on a Flame.  I have passcode enabled for the lockscreen.

It used to be that if I typed 1-3 digits of my passcode at the lockscreen, the key in the lower right corner of the keypad would be a delete key (whereas with 0 digits entered, it's a "Cancel" key).  This no longer happens, and means that if I mistype a digit, I have to start the whole passcode over again, since the key appears as (and is) a Cancel key.
marking for finding out the first bad commit. It seems to be happen in recent days!
We need to branch check first.
Issue is reproducible on Flame 2.2.

Observed behavior: With lockscreen passcode enabled, the keypad on lockscreen doesn't display a delete key no matter how many keys I had typed.

Device: Flame 2.2 Master
BuildID: 20141110053355
Gaia: e02facadb0bc3fe32227b52b31ca47822f7f4322
Gecko: c0d559389a5c
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

----------

Issue is NOT reproducible on Flame 2.1 and Flame 2.0.

Observed behavior: On passcode lockscreen, the 'cancel' key becomes a backspace icon key (delete key) as soon as there's one key entered on it, and it functions correctly.

Device: Flame 2.1
BuildID: 20141110104349
Gaia: 4e3996d6df510b5ec91741ba96161a2a27cc6dbb
Gecko: 7a088bbf2f82
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0
BuildID: 20141110000204
Gaia: d3e4da377ee448f9c25f908159480e867dfb13f3
Gecko: 7198906837e7
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Assignee: nobody → gweng
Posted file Patch
Missing part that should be renamed to adapt the new LockScreenInputWindow and LockScreenInputPad.
Attachment #8520352 - Flags: review?(timdream)
Status: NEW → ASSIGNED
blocking-b2g: --- → 2.2?
master: https://github.com/mozilla-b2g/gaia/commit/e5867911d53ba26f365cd28a2356db8752877b83
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Thanks; it's working again now.
Status: RESOLVED → VERIFIED
Blocking 2.2+ for all fixed regressions.
blocking-b2g: 2.2? → 2.2+
Target Milestone: --- → 2.1 S9 (21Nov)
You need to log in before you can comment on or make changes to this bug.